aboutsummaryrefslogtreecommitdiffstats
path: root/conf.d/packaging/rpm/agl-xds-gdb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'conf.d/packaging/rpm/agl-xds-gdb.spec')
-rw-r--r--conf.d/packaging/rpm/agl-xds-gdb.spec41
1 files changed, 41 insertions, 0 deletions
diff --git a/conf.d/packaging/rpm/agl-xds-gdb.spec b/conf.d/packaging/rpm/agl-xds-gdb.spec
new file mode 100644
index 0000000..178b77d
--- /dev/null
+++ b/conf.d/packaging/rpm/agl-xds-gdb.spec
@@ -0,0 +1,41 @@
+#
+# spec file for package agl-xds-gdb
+#
+
+%define _prefix /opt/AGL
+%global debug_package %{nil}
+
+Name: agl-xds-gdb
+Version: 1.0.2
+Release: 0
+License: Apache-2.0
+Summary: Wrapper on gdb debugger for XDS
+Url: https://github.com/iotbzh/xds-gdb.git
+Source0: xds-gdb_linux-amd64-v1.0.2_2018-04-05_131503.zip
+BuildRequires: unzip
+BuildRoot: %{_tmppath}/%{name}-%{version}-build
+
+%description
+xds-gdb is an agent that should run on your local machine when you use XDS
+
+%prep
+%setup -q -n xds-gdb
+
+%build
+
+%install
+mkdir -p %{?buildroot}%{_prefix}/xds/gdb %{?buildroot}%{_bindir}
+cp xds-gdb %{?buildroot}%{_prefix}/xds/gdb
+ln -s ../xds/gdb/xds-gdb %{?buildroot}%{_bindir}/xds-gdb
+mkdir -p %{?buildroot}%{_sysconfdir}/profile.d
+sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-gdb.sh > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
+
+%files
+%defattr(-,root,root)
+%dir %{_prefix}
+%dir %{_bindir}
+%dir %{_prefix}/xds
+%dir %{_prefix}/xds/gdb
+%{_prefix}/xds/gdb/*
+%{_prefix}/bin/xds-gdb
+%config %{_sysconfdir}/profile.d/%{name}.sh