summaryrefslogtreecommitdiffstats
path: root/test/fixtures/helloworld/helloworld/CMakeLists.txt
diff options
context:
space:
mode:
authorClément Bénier <clement.benier@iot.bzh>2018-08-17 16:45:30 +0200
committerClément Bénier <clement.benier@iot.bzh>2018-08-21 11:08:36 +0200
commitcf3266b208d3ba0fb8f172c29725768bbd41d509 (patch)
tree38d02eebce990c9483c6fcc92497c85ecd3479c6 /test/fixtures/helloworld/helloworld/CMakeLists.txt
parent2b69031e72c3f8370804ceacb8fab7b8899d14f3 (diff)
test exec: remove git2go and cloning afb-helloworld
replace it by fixtures in test/helloworld and copying repo to XDS_SERVER_ROOT_CFG_DIR and cloning app-templates repo into it Change-Id: I4f3d9cfae0f1b81bd7994e172235b1fbc25fd383 Signed-off-by: Clément Bénier <clement.benier@iot.bzh>
Diffstat (limited to 'test/fixtures/helloworld/helloworld/CMakeLists.txt')
-rw-r--r--test/fixtures/helloworld/helloworld/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/test/fixtures/helloworld/helloworld/CMakeLists.txt b/test/fixtures/helloworld/helloworld/CMakeLists.txt
new file mode 100644
index 0000000..373a6f5
--- /dev/null
+++ b/test/fixtures/helloworld/helloworld/CMakeLists.txt
@@ -0,0 +1,36 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(helloworld)
+
+ # Define project Targets
+ file(GLOB sourcelist "*.c")
+
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${sourcelist})
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX ""
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ ${link_libraries}
+ )