aboutsummaryrefslogtreecommitdiffstats
path: root/test/fixtures/helloworld/helloworld/CMakeLists.txt
diff options
context:
space:
mode:
authorClément Bénier <clement.benier@iot.bzh>2018-08-21 18:58:26 +0200
committerClément Bénier <clement.benier@iot.bzh>2018-08-21 18:58:32 +0200
commitc095e1ea9a9e38f020ce4ae852d97c712be910b6 (patch)
treece085c43116ceb9eda10fd79cfc3d18ecfe6387a /test/fixtures/helloworld/helloworld/CMakeLists.txt
parent3c40079d8360c15f0ce52a6c11a2bc2555177463 (diff)
parent2fb2226b666e7a8a21dc8b852188b75c06e2cfc8 (diff)
Merge remote-tracking branch 'origin/sandbox/benierc/test'
Change-Id: Idc200f10e217119df9edfebbaf839c5fd45b19a4 Signed-off-by: Clément Bénier <clement.benier@iot.bzh>
Diffstat (limited to 'test/fixtures/helloworld/helloworld/CMakeLists.txt')
-rw-r--r--test/fixtures/helloworld/helloworld/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/test/fixtures/helloworld/helloworld/CMakeLists.txt b/test/fixtures/helloworld/helloworld/CMakeLists.txt
new file mode 100644
index 0000000..373a6f5
--- /dev/null
+++ b/test/fixtures/helloworld/helloworld/CMakeLists.txt
@@ -0,0 +1,36 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(helloworld)
+
+ # Define project Targets
+ file(GLOB sourcelist "*.c")
+
+ # Define project Targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${sourcelist})
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX ""
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ ${link_libraries}
+ )