summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2017-10-23 13:41:11 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2017-10-26 12:53:12 +0900
commita3e101c1f05e8135ec4e91cea783b61db50c9442 (patch)
tree42b06f526efd398ecc46c0afa19b57a5319cd34a /CMakeLists.txt
parent8fdabf2110b13f1e3aea6e27df938d12894e9b01 (diff)
Add splitted library from agl-service-soundmanager
Related commit: https://gerrit.automotivelinux.org/gerrit/#/c/11421/ [Patch Sets 2] Remove trailing space Bug-AGL: SPEC-993 Change-Id: Ia4c78dfed6fea430993b82ff345b4a45eb647aa7 Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..03d86f6
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,40 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project(libsoundmanager CXX)
+
+cmake_minimum_required(VERSION 2.8)
+
+set(PROJECT_NAME "Soundmanager client library")
+set(PROJECT_VERSION "1.0")
+set(PROJECT_PRETTY_NAME "libsm")
+set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
+set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+
+# get pkgconfig
+INCLUDE(FindPkgConfig)
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
+
+set(CMAKE_BUILD_TYPE Debug)
+add_definitions(-DDEBUGMODE)
+
+add_subdirectory(src)
+
+#generate configure file
+configure_file(soundmanager.pc.in soundmanager.pc @ONLY)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/soundmanager.pc
+ DESTINATION
+ ${CMAKE_INSTALL_LIBDIR}/pkgconfig)