summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnusha Gugale <external.agogale@jp.adit-jv.com>2020-11-25 10:27:43 -0500
committerKenji Hosokawa <khosokawa@jp.adit-jv.com>2020-12-16 22:52:08 +0900
commit18c820b710c10f036b407f33e6c14bfad27d30e1 (patch)
treef86beb3a66bf59e7109a78a25337dab4b408daa5 /CMakeLists.txt
parent92895f025efd9b54f634212cff5bfff1076bd11b (diff)
create .pc(pkg-config) file
Signed-off-by: Anusha Gugale <external.agogale@jp.adit-jv.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ccfe4b..bfb4fbe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -106,4 +106,14 @@ endforeach()
message(STATUS "*** dump end ***")
endif(DEBUG_CMAKE)
+configure_file(
+ "${CMAKE_CURRENT_SOURCE_DIR}/librba.pc.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/librba.pc"
+ @ONLY
+)
+
+install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/librba.pc"
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig"
+)
# end of file