aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/app-svc/files
diff options
context:
space:
mode:
authorKazumasa Mitsunari <kazumasa_mitsunari_za@mail.toyota.co.jp>2016-09-23 16:28:50 +0900
committerKazumasa Mitsunari <kazumasa_mitsunari_za@mail.toyota.co.jp>2016-09-23 16:28:50 +0900
commit33d118c50c6c67ac55271a0f1c0bfdf82ece5c75 (patch)
tree5d7daab26640d29d0730bbad3b9ae8ddda85847c /meta-application-manager/recipes-application-framework/app-svc/files
parent18bd43272c0eb03ddf403d14cdb15f37695d5374 (diff)
Remove efl dependencies of tizen application manager
Removed efl dependencies of tizen application manager. Application could register own event callback function to efl, but AGL has to collaborate with other runtime engine cores. So temporarily disconnected efl event delivery. However, the efl dependencies of amhelloworld(sample applicaiton) is not removed. So, if the error about efl dependencies at scratch build, please let me know. Change-Id: I76b1b3a3575db56b651eabbfd0e0da0b42b708f4 Signed-off-by: Kazumasa Mitsunari <kazumasa_mitsunari_za@mail.toyota.co.jp>
Diffstat (limited to 'meta-application-manager/recipes-application-framework/app-svc/files')
-rw-r--r--meta-application-manager/recipes-application-framework/app-svc/files/0001_remove-ecore-related-functions.patch173
1 files changed, 173 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/app-svc/files/0001_remove-ecore-related-functions.patch b/meta-application-manager/recipes-application-framework/app-svc/files/0001_remove-ecore-related-functions.patch
new file mode 100644
index 0000000..4f34421
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/app-svc/files/0001_remove-ecore-related-functions.patch
@@ -0,0 +1,173 @@
+diff --git a/app-svc/src/appsvc.c b/app-svc/src/appsvc.c
+index f6d6766..a3e393a 100644
+--- a/src/appsvc.c
++++ b/src/appsvc.c
+@@ -30,10 +30,10 @@
+ #include <libsoup/soup.h>
+
+ #ifndef WAYLAND
+-#include <Ecore_X.h>
++//#include <Ecore_X.h>
+ #endif
+
+-#include <Ecore.h>
++//#include <Ecore.h>
+ #include <iniparser.h>
+ #include <pkgmgr-info.h>
+
+@@ -1073,7 +1073,7 @@
+ appsvc_host_res_fn cb_func;
+
+ #ifndef WAYLAND
+- Ecore_X_Window win_id;
++ //Ecore_X_Window win_id;
+ #endif
+
+ void *data;
+@@ -1079,6 +1079,9 @@ typedef struct _appsvc_transient_cb_info_t{
+ void *data;
+ }appsvc_transient_cb_info_t;
+
++/*
++* cut callback function from efl main loop
++*
+ static Eina_Bool __transient_cb(void *data, int type, void *event)
+ {
+ #ifndef WAYLAND
+@@ -1095,7 +1098,7 @@ static Eina_Bool __transient_cb(void *data, int type, void *event)
+ #endif
+ return ECORE_CALLBACK_RENEW;
+ }
+-
++*/
+ int __aul_subapp_cb(void *data)
+ {
+ appsvc_transient_cb_info_t* cb_info;
+@@ -1106,7 +1106,7 @@
+ cb_info = (appsvc_transient_cb_info_t*) data;
+
+ cb_info->cb_func(cb_info->data);
+- ecore_main_loop_quit();
++ //ecore_main_loop_quit();
+
+ return 0;
+ }
+@@ -1107,7 +1110,7 @@ int __aul_subapp_cb(void *data)
+
+ return 0;
+ }
+-
++/*
+ #ifndef WAYLAND
+ SLPAPI int appsvc_allow_transient_app(bundle *b, Ecore_X_Window id)
+ {
+@@ -1155,7 +1158,7 @@ SLPAPI int appsvc_request_transient_app(bundle *b, Ecore_X_Window callee_id, app
+ info->cb_func = cbfunc;
+ info->data = data;
+
+- ecore_event_handler_add(ECORE_X_EVENT_WINDOW_DESTROY, __transient_cb, info);
++ //ecore_event_handler_add(ECORE_X_EVENT_WINDOW_DESTROY, __transient_cb, info);
+ aul_set_subapp(__aul_subapp_cb, info);
+
+ return 0;
+@@ -1166,7 +1169,7 @@ SLPAPI int appsvc_request_transient_app(bundle *b, unsigned int callee_id, appsv
+ return 0;
+ }
+ #endif
+-
++*/
+ SLPAPI int appsvc_subapp_terminate_request_pid(int pid)
+ {
+ return aul_subapp_terminate_request_pid(pid);
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -22,12 +22,12 @@
+ # Set required packages
+ INCLUDE(FindPkgConfig)
+
+-SET(APPSVC_PKGS_CHECK_MODULES "dlog ecore libprivilege-control aul")
+-SET(APPSVC_LIBPKGS_CHECK_MODULES "dlog bundle dbus-glib-1 ail xdgmime aul glib-2.0 ecore libsoup-2.4 iniparser pkgmgr-info libtzplatform-config")
++SET(APPSVC_PKGS_CHECK_MODULES "dlog libprivilege-control aul")
++SET(APPSVC_LIBPKGS_CHECK_MODULES "dlog bundle dbus-glib-1 ail xdgmime aul glib-2.0 libsoup-2.4 iniparser pkgmgr-info libtzplatform-config")
+
+ IF (with_x)
+ pkg_check_modules(pkgs REQUIRED ${APPSVC_PKGS_CHECK_MODULES} x11)
+-pkg_check_modules(libpkgs REQUIRED ${APPSVC_LIBPKGS_CHECK_MODULES} ecore-x)
++pkg_check_modules(libpkgs REQUIRED ${APPSVC_LIBPKGS_CHECK_MODULES})
+ ENDIF(with_x)
+
+ IF (with_wayland)
+
+--- a/test/appsvc_test.c
++++ b/test/appsvc_test.c
+@@ -23,7 +23,7 @@
+ #include <stdio.h>
+ #include <sys/time.h>
+ #include <unistd.h>
+-#include <Ecore.h>
++//#include <Ecore.h>
+ #include <aul.h>
+
+ #include "appsvc.h"
+@@ -197,7 +197,7 @@
+
+ if(strcmp(cmd,"run_svc_res")==0){
+ printf("==== end of appsvc_run() ====\n");
+- ecore_main_loop_quit();
++ //ecore_main_loop_quit();
+ }
+ }
+
+@@ -292,18 +292,18 @@
+ }
+
+
+-static Eina_Bool run_func(void *data)
+-{
+- callfunc(cmd);
+-
+- if(strcmp(cmd,"run_svc_res") == 0 )
+- return 0;
+- else
+- ecore_main_loop_quit();
+-
+- return 0;
+-}
+-
++/* static Eina_Bool run_func(void *data)
++ * {
++ * callfunc(cmd);
++ *
++ * if(strcmp(cmd,"run_svc_res") == 0 )
++ * return 0;
++ * else
++ * ecore_main_loop_quit();
++ *
++ * return 0;
++ * }
++ */
+
+ int main(int argc, char** argv)
+ {
+@@ -312,7 +312,7 @@
+ exit(0);
+ }
+
+- ecore_init();
++ //ecore_init();
+
+ cmd = argv[1];
+ gargc = argc;
+@@ -324,9 +324,9 @@
+ //aul_listen_app_dead_signal(dead_tracker,NULL);
+ //aul_listen_app_dead_signal(NULL,NULL);
+
+- ecore_idler_add(run_func, NULL);
++ //ecore_idler_add(run_func, NULL);
+
+- ecore_main_loop_begin();
++ //ecore_main_loop_begin();
+
+ return 0;
+ }