aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/app-checker/app-checker
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-application-framework/app-checker/app-checker')
-rw-r--r--meta-application-manager/recipes-application-framework/app-checker/app-checker/0001-yocto-Correct-libdl-linking-issue.patch30
-rw-r--r--meta-application-manager/recipes-application-framework/app-checker/app-checker/remove-dlog-for-native-build.patch49
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/app-checker/app-checker/0001-yocto-Correct-libdl-linking-issue.patch b/meta-application-manager/recipes-application-framework/app-checker/app-checker/0001-yocto-Correct-libdl-linking-issue.patch
new file mode 100644
index 0000000..09f7f63
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/app-checker/app-checker/0001-yocto-Correct-libdl-linking-issue.patch
@@ -0,0 +1,30 @@
+From 08d9a48423ff699e20eda48e07d78387f5aecb73 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?K=C3=A9vin=20THIERRY?= <kevin.thierry@open.eurogiciel.org>
+Date: Mon, 7 Jul 2014 14:01:46 +0200
+Subject: [PATCH] [yocto] Correct libdl linking issue
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Change-Id: Icedff39ddd6e458d0e567a519ba53ba51c5683b9
+Signed-off-by: Kévin THIERRY <kevin.thierry@open.eurogiciel.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 61416f8..a476415 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -24,7 +24,7 @@ INCLUDE(FindPkgConfig)
+ pkg_check_modules(pkgs REQUIRED dlog glib-2.0)
+ pkg_check_modules(libpkgs REQUIRED dlog glib-2.0)
+
+-FIND_LIBRARY(LIB_DL dl)
++FIND_LIBRARY(LIB_DL NAMES dl libdl.so.2)
+
+ FOREACH(flag ${libpkgs_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+--
+1.8.1.4
+
diff --git a/meta-application-manager/recipes-application-framework/app-checker/app-checker/remove-dlog-for-native-build.patch b/meta-application-manager/recipes-application-framework/app-checker/app-checker/remove-dlog-for-native-build.patch
new file mode 100644
index 0000000..d258faf
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/app-checker/app-checker/remove-dlog-for-native-build.patch
@@ -0,0 +1,49 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 149d0a6..d77d931 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,10 +21,9 @@ MESSAGE("Build type: ${CMAKE_BUILD_TYPE}")
+ # Set required packages
+ INCLUDE(FindPkgConfig)
+
+-pkg_check_modules(pkgs REQUIRED dlog glib-2.0)
+-pkg_check_modules(libpkgs REQUIRED dlog glib-2.0)
++pkg_check_modules(pkgs REQUIRED glib-2.0)
++pkg_check_modules(libpkgs REQUIRED glib-2.0)
+
+-FIND_LIBRARY(LIB_DL NAMES dl libdl.so.2)
+
+ FOREACH(flag ${libpkgs_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+@@ -79,7 +78,7 @@ add_library(${DAEMON_NAME} SHARED
+ src/ac_sock.c
+ )
+
+-target_link_libraries(${DAEMON_NAME} ${pkgs_LDFLAGS} ${LIB_DL})
++target_link_libraries(${DAEMON_NAME} ${pkgs_LDFLAGS} )
+ SET_TARGET_PROPERTIES(${DAEMON_NAME} PROPERTIES SOVERSION ${VERSION_MAJOR})
+ SET_TARGET_PROPERTIES(${DAEMON_NAME} PROPERTIES VERSION ${VERSION})
+
+diff --git a/include/internal.h b/include/internal.h
+index 731263d..9bdc438 100755
+--- a/include/internal.h
++++ b/include/internal.h
+@@ -25,7 +25,6 @@
+
+ #include <unistd.h>
+ #include <ctype.h>
+-#include <dlog.h>
+
+ #undef LOG_TAG
+ #define LOG_TAG "APP_CHECKER"
+@@ -39,8 +38,8 @@ struct ac_data {
+ int pid;
+ };
+
+-#define _E(fmt, arg...) LOGE(fmt,##arg)
+-#define _D(fmt, arg...) LOGD(fmt,##arg)
++#define _E(fmt, arg...) //LOGE(fmt,##arg)
++#define _D(fmt, arg...) //LOGD(fmt,##arg)
+
+ #define retvm_if(expr, val, fmt, arg...) do { \
+ if(expr) { \