aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch')
-rw-r--r--meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch b/meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch
new file mode 100644
index 0000000..00c9a84
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c3c5f4d..6057c9e 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,7 +25,9 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
+ INCLUDE(FindPkgConfig)
+
+ pkg_check_modules(glib_pkg REQUIRED gobject-2.0)
+-pkg_check_modules(pkgs REQUIRED glib-2.0 dlog libtzplatform-config)
++pkg_check_modules(pkgs REQUIRED glib-2.0 libtzplatform-config)
++ADD_DEFINITIONS("-DUTIL_SYSLOG_OUT")
++
+ FOREACH(flag ${pkgs_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+ ENDFOREACH(flag)