aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/heynoti
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-application-framework/heynoti')
-rw-r--r--meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch15
-rw-r--r--meta-application-manager/recipes-application-framework/heynoti/heynoti-extraconf.inc3
-rw-r--r--meta-application-manager/recipes-application-framework/heynoti/heynoti.inc145
-rw-r--r--meta-application-manager/recipes-application-framework/heynoti/heynoti_git.bb10
4 files changed, 173 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch b/meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch
new file mode 100644
index 0000000..00c9a84
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/heynoti/files/remove_dlog.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c3c5f4d..6057c9e 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,7 +25,9 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
+ INCLUDE(FindPkgConfig)
+
+ pkg_check_modules(glib_pkg REQUIRED gobject-2.0)
+-pkg_check_modules(pkgs REQUIRED glib-2.0 dlog libtzplatform-config)
++pkg_check_modules(pkgs REQUIRED glib-2.0 libtzplatform-config)
++ADD_DEFINITIONS("-DUTIL_SYSLOG_OUT")
++
+ FOREACH(flag ${pkgs_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+ ENDFOREACH(flag)
diff --git a/meta-application-manager/recipes-application-framework/heynoti/heynoti-extraconf.inc b/meta-application-manager/recipes-application-framework/heynoti/heynoti-extraconf.inc
new file mode 100644
index 0000000..1104884
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/heynoti/heynoti-extraconf.inc
@@ -0,0 +1,3 @@
+DEPENDS_remove_class-native = "dlog-native"
+
+SRC_URI_append_class-native = " file://remove_dlog.patch" \ No newline at end of file
diff --git a/meta-application-manager/recipes-application-framework/heynoti/heynoti.inc b/meta-application-manager/recipes-application-framework/heynoti/heynoti.inc
new file mode 100644
index 0000000..a899abc
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/heynoti/heynoti.inc
@@ -0,0 +1,145 @@
+DESCRIPTION = "HEY (ligHt Easy speedy) notification library"
+HOMEPAGE = "http://nohomepage.org"
+SECTION = "System/Libraries"
+LICENSE = "Apache-2.0"
+PV = "0.0.2"
+
+SRC_URI = ""
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep
+
+BBCLASSEXTEND = ""
+PROVIDES = ""
+
+#PROVIDES by heynoti
+
+
+#PROVIDES by heynoti-dev
+PROVIDES += "heynoti-dev"
+
+
+RDEPENDS = ""
+#RDEPENDS of heynoti-dev (${PN}-dev)
+RDEPENDS_${PN}-dev += "heynoti"
+
+
+DEPENDS = ""
+#DEPENDS of heynoti
+inherit tizen_cmake
+DEPENDS += "tizen-platform-config"
+inherit pkgconfig
+DEPENDS += "dlog"
+DEPENDS += "glib-2.0"
+DEPENDS += "ecore"
+
+do_prep() {
+ cd ${S}
+ chmod -Rf a+rX,u+w,g-w,o-w ${S}
+ #setup -q
+ cp ${S}/packaging/heynoti.manifest .
+
+
+
+}
+do_patch_append() {
+ bb.build.exec_func('do_prep', d)
+}
+
+do_configure() {
+}
+
+do_compile() {
+ cd ${S}
+ LANG=C
+ export LANG
+ unset DISPLAY
+ LD_AS_NEEDED=1; export LD_AS_NEEDED ;
+
+
+ cmake \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DCMAKE_INSTALL_PREFIX:PATH=${prefix} \
+ -DCMAKE_INSTALL_LIBDIR:PATH=${prefix}/lib \
+ -DINCLUDE_INSTALL_DIR:PATH=${prefix}/include \
+ -DLIB_INSTALL_DIR:PATH=${prefix}/lib \
+ -DSYSCONF_INSTALL_DIR:PATH=${sysconfdir} \
+ -DSHARE_INSTALL_PREFIX:PATH=${prefix}/share \
+ -DCMAKE_SKIP_RPATH:BOOL=ON \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmake \
+ ${EXTRA_OECMAKE} . -DCMAKE_BUILD_TYPE="Debug"
+
+
+ make ${PARALLEL_MAKE}
+
+
+
+}
+
+do_install() {
+ export RPM_BUILD_ROOT=${D}
+ cd ${S}
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf ${D}
+ mkdir -p ${D}
+
+
+ oe_runmake \
+ DESTDIR=${D} \
+ INSTALL_ROOT=${D} \
+ BINDIR=${prefix}/bin \
+ install
+ rm -f ${D}${infodir}/dir
+ find ${D} -regex ".*\.la$" | xargs rm -f --
+ find ${D} -regex ".*\.a$" | xargs rm -f --
+
+ mkdir -p ${D}${prefix}/share/noti
+ mkdir -p ${D}/usr/share/license
+ install LICENSE ${D}/usr/share/license/heynoti
+
+
+}
+
+pkg_postinst_${PN}() {
+ #!/bin/sh -e
+
+ [ "x$D" == "x" ] && ldconfig
+}
+
+pkg_postrm_${PN}() {
+ #!/bin/sh -e
+
+ [ "x$D" == "x" ] && ldconfig
+}
+
+PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-locale"
+PACKAGES += " heynoti "
+PACKAGES += " heynoti-dev "
+
+heynoti_files = ""
+heynoti_files += "${prefix}/lib/libheynoti.so.0"
+heynoti_files += "${prefix}/lib/libheynoti.so.0.0.2"
+heynoti_files += "${prefix}/bin/heynotitool"
+heynoti_files += "${prefix}/share/noti"
+heynoti_files += "/usr/share/license/heynoti"
+MANIFESTFILES_${PN} = "heynoti.manifest"
+
+heynoti-dev_files = ""
+heynoti-dev_files += "${prefix}/include/heynoti/SLP_Heynoti_PG.h"
+heynoti-dev_files += "${prefix}/include/heynoti/heynoti.h"
+heynoti-dev_files += "${prefix}/lib/pkgconfig/heynoti.pc"
+heynoti-dev_files += "${prefix}/lib/libheynoti.so"
+MANIFESTFILES_${PN}-dev = "heynoti.manifest"
+
+FILES_${PN} = "${heynoti_files}"
+FILES_${PN}-dev = "${heynoti-dev_files}"
+
+PKG_heynoti= "heynoti"
+PKG_heynoti-dev= "heynoti-dev"
+
+require heynoti-extraconf.inc
+
diff --git a/meta-application-manager/recipes-application-framework/heynoti/heynoti_git.bb b/meta-application-manager/recipes-application-framework/heynoti/heynoti_git.bb
new file mode 100644
index 0000000..d1b16a6
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/heynoti/heynoti_git.bb
@@ -0,0 +1,10 @@
+require heynoti.inc
+
+PRIORITY = "10"
+
+LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI += "git://review.tizen.org/platform/core/appfw/heynoti;tag=3f82d6115368fb5a2d799436aecc7b339e6ae373;nobranch=1"
+
+BBCLASSEXTEND += " native "
+