aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info')
-rw-r--r--meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/TizenCommonCMakeMacro.patch38
-rw-r--r--meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/remove-dlog-for-native-build.patch71
2 files changed, 109 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/TizenCommonCMakeMacro.patch b/meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/TizenCommonCMakeMacro.patch
new file mode 100644
index 0000000..1983693
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/TizenCommonCMakeMacro.patch
@@ -0,0 +1,38 @@
+From fba91e42f737956fb27ef8ef75955ada9eef0539 Mon Sep 17 00:00:00 2001
+From: Xavier Roche <xavrock.os@gmail.com>
+Date: Fri, 16 May 2014 18:05:01 +0200
+Subject: [PATCH] Removing TizenCommon macro in packaging
+
+Signed-off-by: Xavier Roche <xavrock.os@gmail.com>
+---
+ CMakeLists.txt | 1 -
+ parser/CMakeLists.txt | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bd24c9c..513d28a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,7 +5,6 @@ PROJECT(pkgmgr-info C)
+
+ SET(VERSION 0.0.17)
+ SET(VERSION_MAJOR 0)
+-INCLUDE(TizenCommon)
+
+ SET(PREFIX ${CMAKE_INSTALL_PREFIX})
+ SET(EXEC_PREFIX "\${prefix}")
+diff --git a/parser/CMakeLists.txt b/parser/CMakeLists.txt
+index 8904ecc..f183758 100755
+--- a/parser/CMakeLists.txt
++++ b/parser/CMakeLists.txt
+@@ -6,7 +6,6 @@ cmake_minimum_required(VERSION 2.6)
+ #set(CMAKE_SKIP_BUILD_RPATH true)
+ set(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS true)
+
+-INCLUDE(TizenCommon)
+
+ ### Versioning
+ if(DEFINED ${VERSION})
+--
+1.7.9.5
+
diff --git a/meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/remove-dlog-for-native-build.patch b/meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/remove-dlog-for-native-build.patch
new file mode 100644
index 0000000..bf83830
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/pkgmgr-info/pkgmgr-info/remove-dlog-for-native-build.patch
@@ -0,0 +1,71 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7b9f75d..216d778 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -18,14 +18,14 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/src ${CMAKE_
+
+ ### Required packages
+ INCLUDE(FindPkgConfig)
+-pkg_check_modules(pkgs REQUIRED glib-2.0 dlog vconf sqlite3 db-util libxml-2.0 dbus-1 dbus-glib-1 libtzplatform-config libsmack)
++pkg_check_modules(pkgs REQUIRED glib-2.0 vconf sqlite3 db-util libxml-2.0 dbus-1 dbus-glib-1 libtzplatform-config libsmack)
+
+ FOREACH(flag ${pkgs_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+ ENDFOREACH(flag)
+
+
+-pkg_check_modules(libpkgs REQUIRED glib-2.0 dlog vconf sqlite3 db-util libxml-2.0 dbus-1 dbus-glib-1 libtzplatform-config libsmack)
++pkg_check_modules(libpkgs REQUIRED glib-2.0 vconf sqlite3 db-util libxml-2.0 dbus-1 dbus-glib-1 libtzplatform-config libsmack)
+
+ FOREACH(flag ${libpkgs_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+diff --git a/parser/CMakeLists.txt b/parser/CMakeLists.txt
+index 8904ecc..1968805 100755
+--- a/parser/CMakeLists.txt
++++ b/parser/CMakeLists.txt
+@@ -26,7 +26,7 @@ message(STATUS "version/major : ${VERSION} / ${VERSION_MAJOR}")
+ ### Get required CFLAGS, LDFLAGS from pkg-config
+
+ include(FindPkgConfig)
+-pkg_check_modules(parser_pkgs REQUIRED dlog libxml-2.0 glib-2.0 sqlite3 db-util vconf)
++pkg_check_modules(parser_pkgs REQUIRED libxml-2.0 glib-2.0 sqlite3 db-util vconf)
+
+ foreach(flag ${parser_pkgs_CFLAGS})
+ set(parser_pkgs_CFLAGS_str "${parser_pkgs_CFLAGS_str} ${flag}")
+diff --git a/include/pkgmgr-info-debug.h b/include/pkgmgr-info-debug.h
+index 061fc50..809c048 100644
+--- a/include/pkgmgr-info-debug.h
++++ b/include/pkgmgr-info-debug.h
+@@ -22,12 +22,14 @@
+ #ifndef __PKGMGR_INFO_DEBUG_H__
+ #define __PKGMGR_INFO_DEBUG_H__
+
+-#include <dlog.h>
+-
+-#define _LOGE(fmt, arg...) LOGE(fmt, ##arg)
+-#define _LOGD(fmt, arg...) LOGD(fmt, ##arg)
++#define NATIVEFAKELOG(fmt, ...) \
++ do\
++ {\
++ printf("\n [%s: %s(): %d] " fmt"\n", rindex(__FILE__, '/')+1, __FUNCTION__, __LINE__, ##__VA_ARGS__);\
++ } while (0)
+
+-#define PKGMGR_INFO_ENABLE_DLOG
++#define _LOGE(fmt, arg...) NATIVEFAKELOG(fmt, ##arg)
++#define _LOGD(fmt, arg...) NATIVEFAKELOG(fmt, ##arg)
+
+ #define COLOR_RED "\033[0;31m"
+ #define COLOR_BLUE "\033[0;34m"
+@@ -60,6 +62,12 @@
+ while( 0 )
+
+ #else
++#define PKGMGR_INFO_DEBUG_ERR(fmt, ...)\
++ do\
++ {\
++ printf("\n [%s: %s(): %d] " fmt"\n", rindex(__FILE__, '/')+1, __FUNCTION__, __LINE__, ##__VA_ARGS__);\
++ }while (0)
++
+ #define PKGMGR_INFO_DEBUG(fmt, ...) \
+ do\
+ {\