summaryrefslogtreecommitdiffstats
path: root/bsp/meta-arm/meta-arm-autonomy/conf
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-arm/meta-arm-autonomy/conf
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-arm/meta-arm-autonomy/conf')
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-guest.inc11
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-host.inc9
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/conf/layer.conf34
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/conf/machine/arm64-autonomy-guest.conf17
4 files changed, 71 insertions, 0 deletions
diff --git a/bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-guest.inc b/bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-guest.inc
new file mode 100644
index 00000000..16b9f7ea
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-guest.inc
@@ -0,0 +1,11 @@
+# This files is added when DISTRO_FEATURES contains arm-autonomy-guest
+
+# We need to have ipv4 activated
+DISTRO_FEATURES_append = " ipv4"
+
+# Build a xenguest type image
+IMAGE_CLASSES += "image_types_xenguest"
+IMAGE_FSTYPES += "xenguest"
+
+# xenguest kernel extension to handle initramfs
+KERNEL_CLASSES += "kernel-xenguest"
diff --git a/bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-host.inc b/bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-host.inc
new file mode 100644
index 00000000..bd98ae21
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/conf/distro/include/arm-autonomy-host.inc
@@ -0,0 +1,9 @@
+# This files is added when DISTRO_FEATURES contains arm-autonomy-host
+
+# We need to have xen and ipv4 activated
+DISTRO_FEATURES_append = " xen ipv4"
+
+# Don't include kernels in standard images when building arm-autonomy-host
+# If the kernel image is needed in the rootfs the following should be set from
+# a bbappend: RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "${KERNEL_PACKAGE_NAME}-image"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base ?= ""
diff --git a/bsp/meta-arm/meta-arm-autonomy/conf/layer.conf b/bsp/meta-arm/meta-arm-autonomy/conf/layer.conf
new file mode 100644
index 00000000..739dc811
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/conf/layer.conf
@@ -0,0 +1,34 @@
+# Add layer to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# Add recipes-* directories to BBFILES
+BBFILES += " \
+ ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend \
+ "
+
+BBFILE_COLLECTIONS += "meta-arm-autonomy"
+BBFILE_PATTERN_meta-arm-autonomy = "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-arm-autonomy = "6"
+LAYERDEPENDS_meta-arm-autonomy = " \
+ core \
+ yocto \
+ openembedded-layer \
+ virtualization-layer \
+"
+LAYERSERIES_COMPAT_meta-arm-autonomy = "dunfell"
+
+# We don't activate virtualization feature from meta-virtualization as it
+# brings in lots of stuff we don't need. We need to disable the sanity check
+# otherwise the user will see a warning on each build.
+SKIP_META_VIRT_SANITY_CHECK = "1"
+
+# Directory of our distro config files
+ARM_AUTONOMY_DISTRO_CFGDIR = "${LAYERDIR}/conf/distro/include/"
+
+# Add class to handle arm-autonomy distro extensions
+USER_CLASSES_append = " arm-autonomy-features"
+
+BBFILES_DYNAMIC += " \
+ meta-arm-bsp:${LAYERDIR}/dynamic-layers/meta-arm-bsp/*/*/*.bbappend \
+"
diff --git a/bsp/meta-arm/meta-arm-autonomy/conf/machine/arm64-autonomy-guest.conf b/bsp/meta-arm/meta-arm-autonomy/conf/machine/arm64-autonomy-guest.conf
new file mode 100644
index 00000000..8b32fa7a
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/conf/machine/arm64-autonomy-guest.conf
@@ -0,0 +1,17 @@
+#@TYPE: Machine
+#@NAME: Autonomy Guest ARM64 machine
+#@DESCRIPTION: Machine configuration for ARM64 Autonomy Guest
+
+TUNE_FEATURES = "aarch64"
+
+require conf/machine/include/arm/arch-armv8a.inc
+
+KERNEL_IMAGETYPE = "Image"
+
+IMAGE_FSTYPES += "tar.bz2"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "5.4%"
+
+DISTRO_FEATURES += "arm-autonomy-guest"
+