summaryrefslogtreecommitdiffstats
path: root/bsp/meta-arm/meta-arm-autonomy/recipes-devtools/qemu/qemu_%.bbappend
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-arm/meta-arm-autonomy/recipes-devtools/qemu/qemu_%.bbappend
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-arm/meta-arm-autonomy/recipes-devtools/qemu/qemu_%.bbappend')
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-devtools/qemu/qemu_%.bbappend18
1 files changed, 18 insertions, 0 deletions
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-devtools/qemu/qemu_%.bbappend b/bsp/meta-arm/meta-arm-autonomy/recipes-devtools/qemu/qemu_%.bbappend
new file mode 100644
index 00000000..ed63a4e9
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-devtools/qemu/qemu_%.bbappend
@@ -0,0 +1,18 @@
+# Use OVERRIDES to minimize the usage of
+# ${@bb.utils.contains('DISTRO_FEATURES', 'xen', ...
+OVERRIDES_append = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ':xen', '', d)}"
+
+# For Xen we only need the i386 binaries
+QEMU_TARGETS_xen = "i386"
+
+PACKAGECONFIG[noaudio] = "--audio-drv-list='',,"
+PACKAGECONFIG_append_xen = " virtfs noaudio"
+PACKAGECONFIG_remove_xen = "sdl"
+
+# Reduce the qemu package size by splitting it into
+# qemu and qemu-xen packages
+PACKAGES_prepend_xen := "${PN}-xen"
+RDEPENDS_${PN}_xen += "${PN}-xen"
+FILES_${PN}-xen_xen = "${bindir}/qemu-system-i386"
+RDEPENDS_${PN}-xen_xen += "xen-tools-libxenstore xen-tools-libxenctrl \
+ xen-tools-libxenguest"