summaryrefslogtreecommitdiffstats
path: root/bsp/meta-arm/meta-arm-toolchain/recipes-devtools/gcc/gcc_arm-9.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-arm/meta-arm-toolchain/recipes-devtools/gcc/gcc_arm-9.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-arm/meta-arm-toolchain/recipes-devtools/gcc/gcc_arm-9.2.bb')
-rw-r--r--bsp/meta-arm/meta-arm-toolchain/recipes-devtools/gcc/gcc_arm-9.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/bsp/meta-arm/meta-arm-toolchain/recipes-devtools/gcc/gcc_arm-9.2.bb b/bsp/meta-arm/meta-arm-toolchain/recipes-devtools/gcc/gcc_arm-9.2.bb
new file mode 100644
index 00000000..51a08772
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-toolchain/recipes-devtools/gcc/gcc_arm-9.2.bb
@@ -0,0 +1,15 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require recipes-devtools/gcc/gcc-target.inc
+require recipes-devtools/gcc/gcc-arm-common.inc
+
+# Building with thumb enabled on armv4t armv5t fails with
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
+ARMFPARCHEXT_armv6 = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
+ARMFPARCHEXT_armv7a = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
+ARMFPARCHEXT_armv7ve = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
+
+BBCLASSEXTEND = "nativesdk"