summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/dynamic-layers/xfce-layer/recipes-xfce/images/boundary-eval-image-xfce.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-boundary/dynamic-layers/xfce-layer/recipes-xfce/images/boundary-eval-image-xfce.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-boundary/dynamic-layers/xfce-layer/recipes-xfce/images/boundary-eval-image-xfce.bb')
-rw-r--r--bsp/meta-boundary/dynamic-layers/xfce-layer/recipes-xfce/images/boundary-eval-image-xfce.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/bsp/meta-boundary/dynamic-layers/xfce-layer/recipes-xfce/images/boundary-eval-image-xfce.bb b/bsp/meta-boundary/dynamic-layers/xfce-layer/recipes-xfce/images/boundary-eval-image-xfce.bb
new file mode 100644
index 00000000..af83840a
--- /dev/null
+++ b/bsp/meta-boundary/dynamic-layers/xfce-layer/recipes-xfce/images/boundary-eval-image-xfce.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "A XFCE desktop demo image."
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs dev-pkgs"
+
+LICENSE = "MIT"
+
+inherit core-image distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+CORE_IMAGE_BASE_INSTALL += "\
+ packagegroup-core-boot \
+ ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
+ packagegroup-core-x11 \
+ packagegroup-xfce-base \
+ kernel-modules \
+ \
+ nodejs \
+ packagegroup-fsl-gstreamer1.0-full \
+ \
+ flex \
+ gcc \
+ git \
+ m4 \
+ make \
+ iperf3 \
+ libtool \
+ nano \
+ python-compiler \
+ strace \
+ screen \
+ minicom \
+ openssl \
+ cryptodev-module \
+"
+
+# For silex module support uncomment the line below and register your ssh key on our webserver to get access.
+# Silex requires some terms and conditions to be accepted before you can build
+# Please fill out the form located here for access: https://boundarydevices.com/private-git-access/
+#CORE_IMAGE_BASE_INSTALL += "kernel-module-silex linux-firmware-silex"
+
+# Video input demos only on nitrogen6x/sx/7 platform
+# Chromium not on nitrogen7
+CORE_IMAGE_BASE_INSTALL_append_nitrogen6x += "video-input-icon chromium firefox qt5everywheredemo cinematicexperience"
+CORE_IMAGE_BASE_INSTALL_append_nitrogen6x-lite += "chromium firefox"
+CORE_IMAGE_BASE_INSTALL_append_nitrogen6sx += "video-input-icon chromium firefox"
+CORE_IMAGE_BASE_INSTALL_append_nitrogen7 += "video-input-icon"