summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb')
-rw-r--r--bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb b/bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb
new file mode 100644
index 00000000..661a3fe6
--- /dev/null
+++ b/bsp/meta-boundary/recipes-boundary/printer-tools/printer-tools_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Test/Debug tools for thermal printers."
+HOMEPAGE = "https://github.com/boundarydevices/printer-tools"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4bc53cea4911b2abe17c307d0f49a5d8"
+SECTION = "base"
+
+SRCREV = "e219aea844d720e7b03da495862cc1586132e7dd"
+SRCBRANCH = "ftp628"
+SRC_URI = "git://github.com/boundarydevices/printer-tools.git;protocol=git;branch=${SRCBRANCH}"
+
+S = "${WORKDIR}/git/"
+
+DEPENDS += " libpng "
+
+EXTRA_OEMAKE = " 'CC=${CC}' 'CFLAGS=-I${STAGING_INCDIR}' \
+ 'LDFLAGS=-L${STAGING_LIBDIR}' "
+
+do_compile () {
+ oe_runmake all
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}/usr/
+}
+
+FILES_${PN} += "/usr/bin"
+
+INSANE_SKIP_${PN} = "ldflags"
+
+BBCLASSEXTEND = "native"