summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-graphics
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
commit4204309872da5cb401cbb2729d9e2d4869a87f42 (patch)
treec7415e8600205e40ff7e91e8e5f4c411f30329f2 /bsp/meta-boundary/recipes-graphics
parent5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (diff)
Diffstat (limited to 'bsp/meta-boundary/recipes-graphics')
-rw-r--r--bsp/meta-boundary/recipes-graphics/tslib_%.bbappend8
-rw-r--r--bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini29
-rw-r--r--bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini25
-rw-r--r--bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend11
-rw-r--r--bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg/0001-v2-xserver-xorg-Fix-X-server-crash.patch45
-rw-r--r--bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend4
6 files changed, 122 insertions, 0 deletions
diff --git a/bsp/meta-boundary/recipes-graphics/tslib_%.bbappend b/bsp/meta-boundary/recipes-graphics/tslib_%.bbappend
new file mode 100644
index 00000000..2b692897
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/tslib_%.bbappend
@@ -0,0 +1,8 @@
+SRC_URI = "git://github.com/boundarydevices/tslib.git;branch=${SRCBRANCH} \
+"
+SRCBRANCH = "boundary-kergoth"
+SRCREV = "${AUTOREV}"
+
+PACKAGECONFIG = "debounce dejitter linear pthres variance input"
+
+COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|nitrogen6sx|nitrogen7|nitrogen8m|nitrogen8mm)"
diff --git a/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini
new file mode 100644
index 00000000..913b13e5
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mm/weston.ini
@@ -0,0 +1,29 @@
+[core]
+# i.MX: Disable idle timeout
+idle-time=0
+gbm-format=argb8888
+backend=drm-backend.so
+
+#[output]
+#name=HDMI-A-1
+#mode=1920x1080@60
+#transform=90
+
+[output]
+name=DSI-1
+mode=current
+
+[shell]
+#size=1920x1080
+
+#[output]
+#name=HDMI-A-2
+#mode=off
+# WIDTHxHEIGHT Resolution size width and height in pixels
+# off Disables the output
+# preferred Uses the preferred mode
+# current Uses the current crt controller mode
+#transform=90
+
+[screen-share]
+command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
diff --git a/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini
new file mode 100644
index 00000000..3a98b988
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/wayland/weston/mx8mq/weston.ini
@@ -0,0 +1,25 @@
+[core]
+# i.MX: Disable idle timeout
+idle-time=0
+gbm-format=argb8888
+backend=fbdev-backend.so
+
+#[output]
+#name=HDMI-A-1
+#mode=1920x1080@60
+#transform=90
+
+[shell]
+size=1920x1080
+
+#[output]
+#name=HDMI-A-2
+#mode=off
+# WIDTHxHEIGHT Resolution size width and height in pixels
+# off Disables the output
+# preferred Uses the preferred mode
+# current Uses the current crt controller mode
+#transform=90
+
+[screen-share]
+command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
diff --git a/bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend b/bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend
new file mode 100644
index 00000000..6401f1a6
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/wayland/weston_4.0.0.imx.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/weston:"
+
+SRC_URI_append = "${@bb.utils.contains('MACHINE', 'nitrogen8mm', "file://mx8mm/weston.ini", "", d)}"
+SRC_URI_append = "${@bb.utils.contains('MACHINE', 'nitrogen8m', "file://mx8mq/weston.ini", "", d)}"
+
+do_install_append_mx8mm() {
+
+ # install default weston.ini
+ install -D -m 0644 ${WORKDIR}/mx8mm/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
+}
+
diff --git a/bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg/0001-v2-xserver-xorg-Fix-X-server-crash.patch b/bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg/0001-v2-xserver-xorg-Fix-X-server-crash.patch
new file mode 100644
index 00000000..37693d65
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg/0001-v2-xserver-xorg-Fix-X-server-crash.patch
@@ -0,0 +1,45 @@
+From eaeaa8b1d84310d40cf30803b24c2155ce1ee4cb Mon Sep 17 00:00:00 2001
+From: Tom Hochstein <tom.hochstein@nxp.com>
+Date: Mon, 20 May 2019 20:52:15 +0000
+Subject: [PATCH] [v2] xserver-xorg: Fix X server crash
+
+Commit 6a5a4e60373c1386b311b2a8bb666c32d68a9d99 removes the configure of
+useSIGIO option:
+
+xfree86 SIGIO support is reworked to use internal versions of
+OsBlockSIGIO and OsReleaseSIGIO
+
+The check for useSIGIO is no longer needed.
+
+Upstream-Status: Pending
+
+Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
+Signed-off-by: Troy Kisky <troy.kisky@boundarydevices.com>
+---
+ hw/xfree86/os-support/shared/sigio.c | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/hw/xfree86/os-support/shared/sigio.c b/hw/xfree86/os-support/shared/sigio.c
+index 884a71c..be76498 100644
+--- a/hw/xfree86/os-support/shared/sigio.c
++++ b/hw/xfree86/os-support/shared/sigio.c
+@@ -185,9 +185,6 @@ xf86InstallSIGIOHandler(int fd, void (*f) (int, void *), void *closure)
+ int i;
+ int installed = FALSE;
+
+- if (!xf86Info.useSIGIO)
+- return 0;
+-
+ for (i = 0; i < MAX_FUNCS; i++) {
+ if (!xf86SigIOFuncs[i].f) {
+ if (xf86IsPipe(fd))
+@@ -256,9 +253,6 @@ xf86RemoveSIGIOHandler(int fd)
+ int max;
+ int ret;
+
+- if (!xf86Info.useSIGIO)
+- return 0;
+-
+ max = 0;
+ ret = 0;
+ for (i = 0; i < MAX_FUNCS; i++) {
diff --git a/bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend b/bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend
new file mode 100644
index 00000000..7ea8cddd
--- /dev/null
+++ b/bsp/meta-boundary/recipes-graphics/xorg-xserver/xserver-xorg_1.20.1.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-v2-xserver-xorg-Fix-X-server-crash.patch"
+