summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
commit4204309872da5cb401cbb2729d9e2d4869a87f42 (patch)
treec7415e8600205e40ff7e91e8e5f4c411f30329f2 /bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
parent5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (diff)
Diffstat (limited to 'bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend')
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend21
1 files changed, 17 insertions, 4 deletions
diff --git a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend b/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
index b92300e6..a2457cb7 100644
--- a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
+++ b/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
@@ -1,10 +1,23 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files/arm64:"
+FILESEXTRAPATHS_prepend_mx6 := "${THISDIR}/files/arm:"
+FILESEXTRAPATHS_prepend_mx7 := "${THISDIR}/files/arm:"
+FILESEXTRAPATHS_prepend_mx8 := "${THISDIR}/files/arm64:"
SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH} \
- file://defconfig \
"
-LOCALVERSION = "-1.0.0-ga+yocto"
-SRCBRANCH = "boundary-imx_4.14.x_1.0.0_ga"
+LOCALVERSION = "-2.0.0-ga+yocto"
SRCREV = "${AUTOREV}"
COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|nitrogen6sx|nitrogen7|nitrogen8m|nitrogen8mm)"
+
+S = "${WORKDIR}/git"
+
+do_merge_default_config() {
+
+ if [ -f ${S}/arch/${ARCH}/configs/${KERNEL_DEFCONFIG} ]; then
+ # create config with make config
+ oe_runmake -C ${S} O=${KBUILD_OUTPUT} ${KERNEL_DEFCONFIG}
+ cp ${KBUILD_OUTPUT}/.config ${WORKDIR}/defconfig
+ fi
+
+}
+addtask merge_default_config before do_preconfigure after do_patch