summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-kernel/linux
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-boundary/recipes-kernel/linux
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-boundary/recipes-kernel/linux')
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend23
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb22
-rw-r--r--bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb58
3 files changed, 0 insertions, 103 deletions
diff --git a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend b/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
deleted file mode 100644
index a2457cb7..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_%.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
-FILESEXTRAPATHS_prepend_mx6 := "${THISDIR}/files/arm:"
-FILESEXTRAPATHS_prepend_mx7 := "${THISDIR}/files/arm:"
-FILESEXTRAPATHS_prepend_mx8 := "${THISDIR}/files/arm64:"
-
-SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH} \
-"
-
-LOCALVERSION = "-2.0.0-ga+yocto"
-SRCREV = "${AUTOREV}"
-COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|nitrogen6sx|nitrogen7|nitrogen8m|nitrogen8mm)"
-
-S = "${WORKDIR}/git"
-
-do_merge_default_config() {
-
- if [ -f ${S}/arch/${ARCH}/configs/${KERNEL_DEFCONFIG} ]; then
- # create config with make config
- oe_runmake -C ${S} O=${KBUILD_OUTPUT} ${KERNEL_DEFCONFIG}
- cp ${KBUILD_OUTPUT}/.config ${WORKDIR}/defconfig
- fi
-
-}
-addtask merge_default_config before do_preconfigure after do_patch
diff --git a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb b/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb
deleted file mode 100644
index 96cf9cf4..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.14.x.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-# Adapted from linux-imx.inc, copyright (C) 2013, 2014 O.S. Systems Software LTDA
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-require recipes-kernel/linux/linux-imx.inc
-
-SUMMARY = "Linux kernel for Boundary Devices boards"
-
-FILESEXTRAPATHS_prepend_mx6 := "${THISDIR}/${PN}-${PV}/arm:"
-FILESEXTRAPATHS_prepend_mx7 := "${THISDIR}/${PN}-${PV}/arm:"
-FILESEXTRAPATHS_prepend_mx8 := "${THISDIR}/${PN}-${PV}/arm64:"
-
-SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH} \
- file://defconfig \
-"
-
-LOCALVERSION = "-2.0.0-ga+yocto"
-SRCBRANCH = "boundary-imx_4.14.x_2.0.0_ga"
-SRCREV = "${AUTOREV}"
-DEPENDS += "lzop-native bc-native"
-COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|nitrogen6sx|nitrogen7|nitrogen8m)"
-
-KERNEL_DEFCONFIG = "boundary_defconfig"
diff --git a/bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb b/bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb
deleted file mode 100644
index 2040c02f..00000000
--- a/bsp/meta-boundary/recipes-kernel/linux/linux-imx-headers_4.14.x.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2017-2018 NXP
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-SUMMARY = "Installs i.MX-specific kernel headers"
-DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
-New headers are installed in ${includedir}/imx."
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-LOCALVERSION = "-imx"
-SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH}"
-SRCBRANCH = "boundary-imx_4.14.x_2.0.0_ga"
-SRCREV = "${AUTOREV}"
-
-S = "${WORKDIR}/git"
-
-do_compile[noexec] = "1"
-
-IMX_UAPI_HEADERS = " \
- dma-buf.h \
- hantrodec.h \
- hx280enc.h \
- ion.h \
- ipu.h \
- isl29023.h \
- mxc_asrc.h \
- mxc_dcic.h \
- mxc_mlb.h \
- mxc_sim_interface.h \
- mxc_v4l2.h \
- mxcfb.h \
- pxp_device.h \
- pxp_dma.h \
- version.h \
- videodev2.h \
-"
-
-do_install() {
- # We install all headers inside of B so we can copy only the
- # whitelisted ones, and there is no risk of a new header to be
- # installed by mistake.
- oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
-
- # FIXME: The ion.h is still on staging so "promote" it for now
- cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux
-
- # Install whitelisted headers only
- for h in ${IMX_UAPI_HEADERS}; do
- install -D -m 0644 ${B}${includedir}/linux/$h \
- ${D}${includedir}/imx/linux/$h
- done
-}
-
-ALLOW_EMPTY_${PN} = "1"
-
-PACKAGE_ARCH = "${MACHINE_SOCARCH}"
-COMPATIBLE_HOST_imx = ".*"
-COMPATIBLE_HOST ?= "(none)"