summaryrefslogtreecommitdiffstats
path: root/bsp/meta-boundary/recipes-sato
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-boundary/recipes-sato
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-boundary/recipes-sato')
-rw-r--r--bsp/meta-boundary/recipes-sato/images/boundary-eval-image.bb48
-rw-r--r--bsp/meta-boundary/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend2
2 files changed, 50 insertions, 0 deletions
diff --git a/bsp/meta-boundary/recipes-sato/images/boundary-eval-image.bb b/bsp/meta-boundary/recipes-sato/images/boundary-eval-image.bb
new file mode 100644
index 00000000..1e7ec2f4
--- /dev/null
+++ b/bsp/meta-boundary/recipes-sato/images/boundary-eval-image.bb
@@ -0,0 +1,48 @@
+# Basically core-image-sato-dev + extra packages in IMAGE_INSTALL below
+
+DESCRIPTION = "Image with Sato for development work. It includes everything \
+within core-image-sato plus a native toolchain, application development and \
+testing libraries, profiling and debug symbols. \
+Also includes many other packages for a generic Boundary Devices Evaluation Image"
+
+IMAGE_FEATURES += "splash package-management x11-base x11-sato ssh-server-dropbear hwcodecs dev-pkgs"
+
+LICENSE = "MIT"
+
+inherit core-image distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+CONFLICT_DISTRO_FEATURES = "wayland"
+
+CORE_IMAGE_BASE_INSTALL += "\
+ packagegroup-core-x11-sato-games \
+ nodejs \
+ packagegroup-fsl-gstreamer1.0-full \
+ \
+ flex \
+ gcc \
+ git \
+ m4 \
+ make \
+ iperf3 \
+ libtool \
+ nano \
+ python-compiler \
+ strace \
+ screen \
+ minicom \
+ openssl \
+ cryptodev-module \
+"
+
+# For silex module support uncomment the line below and register your ssh key on our webserver to get access.
+# Silex requires some terms and conditions to be accepted before you can build
+# Please fill out the form located here for access: https://boundarydevices.com/private-git-access/
+#CORE_IMAGE_BASE_INSTALL += "kernel-module-silex linux-firmware-silex"
+
+# Video input demos only on nitrogen6x/sx/7 platform
+# Chromium not on nitrogen7
+CORE_IMAGE_BASE_INSTALL_append_nitrogen6x += "video-input-icon chromium firefox qt5everywheredemo cinematicexperience"
+CORE_IMAGE_BASE_INSTALL_append_nitrogen6x-lite += "chromium firefox"
+CORE_IMAGE_BASE_INSTALL_append_nitrogen6sx += "video-input-icon chromium firefox"
+CORE_IMAGE_BASE_INSTALL_append_nitrogen7 += "video-input-icon"
diff --git a/bsp/meta-boundary/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend b/bsp/meta-boundary/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend
new file mode 100644
index 00000000..98970335
--- /dev/null
+++ b/bsp/meta-boundary/recipes-sato/packagegroups/packagegroup-core-x11-sato.bbappend
@@ -0,0 +1,2 @@
+# Get rid of connman
+NETWORK_MANAGER = "networkmanager"