summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale-3rdparty/recipes-bsp/rcw/rcw_git.bbappend
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-freescale-3rdparty/recipes-bsp/rcw/rcw_git.bbappend
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-freescale-3rdparty/recipes-bsp/rcw/rcw_git.bbappend')
-rw-r--r--bsp/meta-freescale-3rdparty/recipes-bsp/rcw/rcw_git.bbappend29
1 files changed, 29 insertions, 0 deletions
diff --git a/bsp/meta-freescale-3rdparty/recipes-bsp/rcw/rcw_git.bbappend b/bsp/meta-freescale-3rdparty/recipes-bsp/rcw/rcw_git.bbappend
new file mode 100644
index 00000000..4384c042
--- /dev/null
+++ b/bsp/meta-freescale-3rdparty/recipes-bsp/rcw/rcw_git.bbappend
@@ -0,0 +1,29 @@
+FILESEXTRAPATHS_append_lx2160acex7 := "${THISDIR}/${PN}-lx2160acex7:"
+
+SRC_URI_append_lx2160acex7 = "\
+ file://0001-lx2160acex7-misc-RCW-files.patch \
+ file://0002-Set-io-pads-as-GPIO.patch \
+ file://0003-S2-enable-gen3-xspi-increase-divisor-to-28.patch \
+ file://0004-refactor-a009531-a008851-and-a011270.patch \
+ file://0006-lx2160a-add-SVR-check-for-a050234-to-apply-only-on-r.patch \
+ file://0007-lx2160acex7-pcie-workarounds-and-fan-full-speed.patch \
+ file://0008-lx2160a-add-generic-bootloc-section.patch \
+ file://0009-lx2160acex7-remove-all-predefined-RCW-files.patch \
+"
+
+do_configure_prepend_lx2160acex7 () {
+ for BT in ${BOARD_TARGETS}
+ do
+ mkdir -p ${S}/${BOARD_TARGETS}/${SERDES}
+ cat <<EOF >${S}/${BOARD_TARGETS}/README
+The RCW directories for lx2160acex7 are created based on existing SERDES
+configuration. Currently created automatically - later maybe by building
+cross product of serdes & ddr speeds in a final commit.
+EOF
+ cat <<EOF >${S}/${BOARD_TARGETS}/${SERDES}/${SPEED}.rcw
+#include <configs/lx2160a_defaults.rcwi>
+#include <configs/lx2160a_${SPEED}.rcwi>
+#include <configs/lx2160a_${SERDES}.rcwi>
+EOF
+ done
+}