summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale-3rdparty/recipes-kernel/linux/linux-boundary_5.4.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-freescale-3rdparty/recipes-kernel/linux/linux-boundary_5.4.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-freescale-3rdparty/recipes-kernel/linux/linux-boundary_5.4.bb')
-rw-r--r--bsp/meta-freescale-3rdparty/recipes-kernel/linux/linux-boundary_5.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/bsp/meta-freescale-3rdparty/recipes-kernel/linux/linux-boundary_5.4.bb b/bsp/meta-freescale-3rdparty/recipes-kernel/linux/linux-boundary_5.4.bb
new file mode 100644
index 00000000..abe3099c
--- /dev/null
+++ b/bsp/meta-freescale-3rdparty/recipes-kernel/linux/linux-boundary_5.4.bb
@@ -0,0 +1,24 @@
+# Adapted from linux-imx.inc, copyright (C) 2013, 2014 O.S. Systems Software LTDA
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require recipes-kernel/linux/linux-imx.inc
+
+SUMMARY = "Linux kernel for Boundary Devices boards"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+LINUX_VERSION = "5.4.50"
+
+SRC_URI = "git://github.com/boundarydevices/linux-imx6.git;branch=${SRCBRANCH} \
+"
+
+LOCALVERSION = "-2.1.0-ga+yocto"
+SRCBRANCH = "boundary-imx_5.4.x_2.1.0"
+SRCREV = "503a3dce966a6b98e7bfdc376477c604a4275c60"
+DEPENDS += "lzop-native bc-native"
+COMPATIBLE_MACHINE = "(nitrogen6x|nitrogen6x-lite|nitrogen6sx|nitrogen7|nitrogen8m|nitrogen8mm|nitrogen8mn)"
+
+KBUILD_DEFCONFIG ?= "boundary_defconfig"
+
+S = "${WORKDIR}/git"