summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb b/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
new file mode 100644
index 00000000..a330c7b0
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
@@ -0,0 +1,35 @@
+# Copyright 2017-2018 NXP
+
+DESCRIPTION = "i.MX Hantro VPU library"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
+
+PROVIDES = "virtual/imxvpu"
+
+SRC_URI = " \
+ ${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
+ file://0001-Get-i.MX-custom-headers-from-usr-include-imx.patch \
+"
+SRC_URI[md5sum] = "140796ddd6f1be47cffb7e5e2bfe0fb6"
+SRC_URI[sha256sum] = "c092a5b0f8897bae54154f58e47b6d2de033da01ee231a8cd779a51bbe962606"
+
+inherit fsl-eula-unpack use-imx-headers
+
+PARALLEL_MAKE="-j 1"
+
+PLATFORM_mx8mm = "IMX8MM"
+PLATFORM_mx8mq = "IMX8MQ"
+
+do_compile () {
+ oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
+ SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
+ PLATFORM="${PLATFORM}" all
+}
+
+do_install () {
+ oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
+}
+
+FILES_${PN} += "/unit_tests"
+
+COMPATIBLE_MACHINE = "(mx8m)"