summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb b/bsp/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb
new file mode 100644
index 00000000..18a63b13
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/ls2-phy/ls2-phy_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Firmwares and Standalone Applications"
+LICENSE = "NXP-Binary-EULA"
+LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798"
+
+inherit deploy fsl-eula-unpack
+
+SRC_URI = "git://github.com/nxp/qoriq-firmware-cortina.git;fsl-eula=true;nobranch=1"
+SRCREV = "9143c2a3adede595966583c00ca4edc99ec698cf"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ install -d ${D}/boot
+ cp -fr ${S}/* ${D}/boot
+}
+
+do_deploy () {
+ install -d ${DEPLOYDIR}/ls2-phy
+ cp -fr ${S}/* ${DEPLOYDIR}/ls2-phy
+}
+addtask deploy before do_build after do_install
+
+PACKAGES += "${PN}-image"
+FILES_${PN}-image += "/boot"
+
+COMPATIBLE_MACHINE = "(ls2080ardb|ls2088ardb|t2080|t4240|lx2160a)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+