summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb b/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
new file mode 100644
index 00000000..430d6cd8
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "The Management Complex (MC) is a key component of DPAA"
+SECTION = "mc-utils"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987 \
+"
+
+DEPENDS += "dtc-native"
+
+inherit deploy
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/mc-utils;nobranch=1"
+SRCREV = "6aca560c630dc54afdef382c506f214b28f4985e"
+
+S = "${WORKDIR}/git"
+
+MC_CFG ?= ""
+MC_CFG_ls1088a = "ls1088a"
+MC_CFG_ls2088a = "ls2088a"
+MC_CFG_lx2160a = "lx2160a"
+
+do_install () {
+ oe_runmake -C config
+
+ install -d ${D}/boot/mc-utils
+ cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils
+ if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
+ install -d ${D}/boot/mc-utils/custom
+ cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom
+ fi
+}
+
+do_deploy () {
+ install -d ${DEPLOYDIR}/mc-utils
+ cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils
+ if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
+ install -d ${DEPLOYDIR}/mc-utils/custom
+ cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
+ fi
+}
+addtask deploy after do_install
+
+PACKAGES += "${PN}-image"
+FILES_${PN}-image += "/boot"
+COMPATIBLE_MACHINE = "(qoriq-arm64)"