summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-bsp/rcw/rcw_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/rcw/rcw_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/rcw/rcw_git.bb b/bsp/meta-freescale/recipes-bsp/rcw/rcw_git.bb
new file mode 100644
index 00000000..c6bdad23
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/rcw/rcw_git.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Reset Configuration Word"
+DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=45a017ee5f4cfe64b1cddf2eb06cffc7"
+
+DEPENDS += "change-file-endianess-native tcl-native"
+
+inherit deploy siteinfo
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/rcw;nobranch=1"
+SRCREV = "17254ac35250197877c6321f9d13e33b1f85388a"
+
+S = "${WORKDIR}/git"
+
+export PYTHON = "${USRBINPATH}/python2"
+
+M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
+
+do_install () {
+ if [ ${M} = ls2088ardb ]; then
+ oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install
+ oe_runmake BOARDS=${M}_rev1.1 DESTDIR=${D}/boot/rcw/ install
+ elif [ ${M} = ls1088ardb-pb ]; then
+ oe_runmake BOARDS=ls1088ardb DESTDIR=${D}/boot/rcw/ install
+ else
+ oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install
+ fi
+}
+
+do_deploy () {
+ install -d ${DEPLOYDIR}/rcw
+ cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/
+}
+addtask deploy after do_install
+
+PACKAGES += "${PN}-image"
+FILES_${PN}-image += "/boot"
+
+COMPATIBLE_MACHINE = "(qoriq)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"