summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2019.04.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2019.04.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2019.04.bb b/bsp/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
new file mode 100644
index 00000000..d37ede83
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
@@ -0,0 +1,35 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2018 (C) O.S. Systems Software LTDA.
+# Copyright 2017-2019 NXP
+
+require recipes-bsp/u-boot/u-boot.inc
+require u-boot-imx-common.inc
+
+SRC_URI += "file://0001-Add-target-to-generate-initial-environment.patch"
+
+PROVIDES += "u-boot"
+
+do_deploy_append_mx8m() {
+ # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ i=$(expr $i + 1);
+ for type in ${UBOOT_CONFIG}; do
+ j=$(expr $j + 1);
+ if [ $j -eq $i ]
+ then
+ install -d ${DEPLOYDIR}/${BOOT_TOOLS}
+ install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
+ install -m 0777 ${B}/${config}/tools/mkimage ${DEPLOYDIR}/${BOOT_TOOLS}/mkimage_uboot
+ install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG}
+ fi
+ done
+ unset j
+ done
+ unset i
+ fi
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"