summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb b/bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
new file mode 100644
index 00000000..aca35a84
--- /dev/null
+++ b/bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Datapath layout examples"
+LICENSE = "Freescale-EULA"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987"
+
+DEPENDS = "dtc-native"
+
+inherit deploy fsl-eula-unpack
+
+SRC_URI = "git://github.com/qoriq-open-source/dpl-examples.git;fsl-eula=true;nobranch=1"
+SRCREV = "a6c83759c0d9c02822eec89e86357a0998ef51d4"
+
+S = "${WORKDIR}/git"
+
+REGLEX_ls2088a = "ls2088a"
+REGLEX_ls1088a = "ls1088a"
+
+do_install () {
+ install -d ${D}/boot
+ install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${D}/boot
+ install -m 644 ${S}/${REGLEX}/RDB/custom/*.dtb ${D}/boot
+}
+
+do_deploy () {
+ install -d ${DEPLOYDIR}/dpl-examples
+ install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${DEPLOYDIR}/dpl-examples
+ install -m 644 ${S}/${REGLEX}/RDB/custom/*.dtb ${DEPLOYDIR}/dpl-examples
+}
+addtask deploy before do_build after do_install
+
+PACKAGES += "${PN}-image"
+FILES_${PN}-image += "/boot"
+
+COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+