summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-dpaa2
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-freescale/recipes-dpaa2
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-freescale/recipes-dpaa2')
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/aiopsl/aiopsl_git.bb11
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb6
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb35
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.14.1.bb (renamed from bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb)9
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.20.4.bb41
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/restool/restool_git.bb4
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/spc/spc_git.bb2
7 files changed, 57 insertions, 51 deletions
diff --git a/bsp/meta-freescale/recipes-dpaa2/aiopsl/aiopsl_git.bb b/bsp/meta-freescale/recipes-dpaa2/aiopsl/aiopsl_git.bb
index 9ba12816..a1b00289 100644
--- a/bsp/meta-freescale/recipes-dpaa2/aiopsl/aiopsl_git.bb
+++ b/bsp/meta-freescale/recipes-dpaa2/aiopsl/aiopsl_git.bb
@@ -8,7 +8,7 @@ BASEDEPENDS = ""
S = "${WORKDIR}/git"
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/aiopsl;nobranch=1"
-SRCREV = "ec0e50b9bfe794b78bf0d91789f2a77dc4e8ceb4"
+SRCREV = "87d83d8e99770325cc7ad9e10965c9959e7cb828"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
@@ -18,11 +18,10 @@ DEMOS_PATH_ls1088a = "LS1088A"
do_install () {
install -d ${D}/usr/aiop/bin
- install -d ${D}/usr/aiop/scripts
- install -d ${D}/usr/aiop/traffic_files
- install -m 755 ${S}/demos/images/${DEMOS_PATH}/*.elf ${D}/usr/aiop/bin
- install -m 755 ${S}/misc/setup/scripts/dynamic_aiop_*.sh ${D}/usr/aiop/scripts
- install -m 644 ${S}/misc/setup/traffic_files/classifier.pcap ${D}/usr/aiop/traffic_files
+ install -d ${D}/usr/aiop/
+ cp -rf ${S}/demos/images/* ${D}/usr/aiop/bin
+ cp -rf ${S}/misc/setup/scripts ${D}/usr/aiop/
+ cp -rf ${S}/misc/setup/traffic_files/ ${D}/usr/aiop/
}
FILES_${PN} += "/usr/aiop/*"
diff --git a/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb b/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb
index 7313ca73..0e31a3c4 100644
--- a/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb
+++ b/bsp/meta-freescale/recipes-dpaa2/dce/dce_git.bb
@@ -1,13 +1,13 @@
DESCRIPTION = "Decompression Compression Engine Userspace Utils"
SECTION = "dpaa2"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=338308e2a663929309c9929ab9495bb5"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=956df5ea6cfe0a1dcf2dee7ca37c0cdf"
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dce;nobranch=1 \
git://source.codeaurora.org/external/qoriq/qoriq-components/qbman_userspace;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \
"
-SRCREV = "49389aa57cc94e0503f53c6b33e4b358ccf42eb5"
-SRCREV_qbman = "383ceac0c09b1e38f2a8b1cf42822686b4cf15f3"
+SRCREV = "0ec35ad12ad04b5dadfa9f8c8a718c715bde41db"
+SRCREV_qbman = "a1af1e1528fe2e1ce0df1e6d9170b6c239c8ab4f"
S = "${WORKDIR}/git"
diff --git a/bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb b/bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
deleted file mode 100644
index aca35a84..00000000
--- a/bsp/meta-freescale/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "Datapath layout examples"
-LICENSE = "Freescale-EULA"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987"
-
-DEPENDS = "dtc-native"
-
-inherit deploy fsl-eula-unpack
-
-SRC_URI = "git://github.com/qoriq-open-source/dpl-examples.git;fsl-eula=true;nobranch=1"
-SRCREV = "a6c83759c0d9c02822eec89e86357a0998ef51d4"
-
-S = "${WORKDIR}/git"
-
-REGLEX_ls2088a = "ls2088a"
-REGLEX_ls1088a = "ls1088a"
-
-do_install () {
- install -d ${D}/boot
- install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${D}/boot
- install -m 644 ${S}/${REGLEX}/RDB/custom/*.dtb ${D}/boot
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/dpl-examples
- install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${DEPLOYDIR}/dpl-examples
- install -m 644 ${S}/${REGLEX}/RDB/custom/*.dtb ${DEPLOYDIR}/dpl-examples
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
-
-COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb b/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
index 6b5d0a87..ddb305c1 100644
--- a/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb
+++ b/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
@@ -2,16 +2,17 @@ SUMMARY = "DPAA2 Management Complex Firmware"
LICENSE = "NXP-Binary-EULA"
LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=afcb1213054384820390d410ab62105f"
-inherit deploy fsl-eula-unpack
+inherit deploy
INHIBIT_DEFAULT_DEPS = "1"
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;fsl-eula=true;nobranch=1"
-SRCREV = "cdb5af4b25ec1ee3e9d26ece41efaa1556b28bac"
+SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1"
+SRCREV = "408110ee632f6291545b0b156cd74e7e3b4612cc"
S = "${WORKDIR}/git"
REGLEX_ls2088a = "ls2088a"
+REGLEX_ls2080a = "ls2080a"
REGLEX_ls1088a = "ls1088a"
REGLEX_lx2160a = "lx2160a"
@@ -24,7 +25,7 @@ do_deploy () {
install -d ${DEPLOYDIR}/mc_app
install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
# make a symlink to the latest binary
- for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
+ for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
done
}
diff --git a/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
new file mode 100644
index 00000000..3e14a26e
--- /dev/null
+++ b/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
@@ -0,0 +1,41 @@
+SUMMARY = "DPAA2 Management Complex Firmware"
+LICENSE = "NXP-Binary-EULA"
+LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=73d4b970c18882e229e4bf1ada5bb8d6"
+
+inherit deploy
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1"
+SRCREV = "f73683596a7b72124d67b62e64f3dc2bb36b9321"
+
+S = "${WORKDIR}/git"
+
+REGLEX_ls2088a = "ls2088a"
+REGLEX_ls2080a = "ls2080a"
+REGLEX_ls1088a = "ls1088a"
+REGLEX_lx2160a = "lx2160a"
+
+do_install () {
+ install -d ${D}/boot
+ install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
+}
+
+do_deploy () {
+ install -d ${DEPLOYDIR}/mc_app
+ install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
+ # make a symlink to the latest binary
+ for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
+ ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
+ done
+}
+addtask deploy before do_build after do_install
+
+PACKAGES += "${PN}-image"
+FILES_${PN}-image += "/boot"
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+COMPATIBLE_MACHINE = "(qoriq-arm64)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
diff --git a/bsp/meta-freescale/recipes-dpaa2/restool/restool_git.bb b/bsp/meta-freescale/recipes-dpaa2/restool/restool_git.bb
index 382e3144..0211c779 100644
--- a/bsp/meta-freescale/recipes-dpaa2/restool/restool_git.bb
+++ b/bsp/meta-freescale/recipes-dpaa2/restool/restool_git.bb
@@ -7,7 +7,7 @@ RDEPENDS_${PN} += "bash dtc"
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1 \
file://0001-restool-fix-build-error-with-gcc7.patch"
-SRCREV = "2b4dd211d5c584d5f81cfa530a3a93854dc1d490"
+SRCREV = "f0cec094e4c6d1c975b377203a3bf994ba9325a9"
S = "${WORKDIR}/git"
@@ -17,6 +17,6 @@ do_install () {
oe_runmake install DESTDIR=${D}
}
-COMPATIBLE_MACHINE = "(ls2080ardb|ls2088ardb|ls1088ardb|ls1043ardb|ls1046ardb)"
+COMPATIBLE_MACHINE = "(qoriq-arm64)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/bsp/meta-freescale/recipes-dpaa2/spc/spc_git.bb b/bsp/meta-freescale/recipes-dpaa2/spc/spc_git.bb
index eceabf91..e9bf1427 100644
--- a/bsp/meta-freescale/recipes-dpaa2/spc/spc_git.bb
+++ b/bsp/meta-freescale/recipes-dpaa2/spc/spc_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=163b09a1c249a6ff2b28da1ceca2e0a8"
DEPENDS = "libxml2 fmlib tclap"
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/spc;nobranch=1"
-SRCREV = "1a414247ad3228bf60bfb53995a28930a8a29acc"
+SRCREV = "be7dd8e346a934aae1e4bdd6b579f2aa4bb5cd86"
S = "${WORKDIR}/git"