summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-extended/crconf
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-freescale/recipes-extended/crconf
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-freescale/recipes-extended/crconf')
-rw-r--r--bsp/meta-freescale/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch30
-rw-r--r--bsp/meta-freescale/recipes-extended/crconf/crconf_git.bb18
2 files changed, 48 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch b/bsp/meta-freescale/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch
new file mode 100644
index 00000000..4459c370
--- /dev/null
+++ b/bsp/meta-freescale/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch
@@ -0,0 +1,30 @@
+From 2c260c8c437c7f72f093b6c157a38b93443bde1d Mon Sep 17 00:00:00 2001
+From: Chunrong Guo <chunrong.guo@nxp.com>
+Date: Mon, 11 Dec 2017 15:45:05 +0800
+Subject: [PATCH] Modify the Makefile for cross compile
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c7bfee2..d6421f3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,8 +4,8 @@ LIBDIR=/usr/lib
+ SBINDIR=/sbin
+ MANDIR=/share/man
+
+-CC = gcc
+-HOSTCC = gcc
++CC ?= gcc
++HOSTCC ?= gcc
+ CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall
+ CFLAGS = $(CCOPTS) -I../include
+
+--
+2.7.4
+
diff --git a/bsp/meta-freescale/recipes-extended/crconf/crconf_git.bb b/bsp/meta-freescale/recipes-extended/crconf/crconf_git.bb
new file mode 100644
index 00000000..7dc92776
--- /dev/null
+++ b/bsp/meta-freescale/recipes-extended/crconf/crconf_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "crconf -Linux crypto layer configuraton tool"
+SECTION = "base"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=5;md5=0f77fc44eb5911007ae4ac9f6736e111"
+
+SRC_URI = "git://github.com/Thermi/crconf.git;protocol=https;nobranch=1"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'HOSTCC=${CC}'"
+
+SRCREV = "7b5819e7638e471d41dd2dca71f012d5a022f014"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} += "/share/man/* ${libdir}/* ${sbindir}/*"