summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-extended/ovs-dpdk
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-freescale/recipes-extended/ovs-dpdk
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-freescale/recipes-extended/ovs-dpdk')
-rw-r--r--bsp/meta-freescale/recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch34
-rw-r--r--bsp/meta-freescale/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb (renamed from bsp/meta-freescale/recipes-extended/ovs-dpdk/ovs-dpdk_2.9.bb)16
2 files changed, 43 insertions, 7 deletions
diff --git a/bsp/meta-freescale/recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch b/bsp/meta-freescale/recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch
new file mode 100644
index 00000000..71b2b58c
--- /dev/null
+++ b/bsp/meta-freescale/recipes-extended/ovs-dpdk/files/0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch
@@ -0,0 +1,34 @@
+From 95c5c42b9581f595881df11ca8393dc6925f7d7d Mon Sep 17 00:00:00 2001
+From: Nipun Gupta <nipun.gupta@nxp.com>
+Date: Thu, 14 Feb 2019 17:57:14 +0530
+Subject: [PATCH] netdev-dpdk: have env based configurable number of packet
+ buffers
+
+use $export DPDK_NUM_MBUF=number
+
+Upstream-Status: Pending
+
+Signed-off-by: Nipun Gupta <nipun.gupta@nxp.com>
+---
+ lib/netdev-dpdk.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/lib/netdev-dpdk.c b/lib/netdev-dpdk.c
+index 6187129c0..1f456a63f 100644
+--- a/lib/netdev-dpdk.c
++++ b/lib/netdev-dpdk.c
+@@ -656,6 +656,11 @@ dpdk_calculate_mbufs(struct netdev_dpdk *dev, int mtu, bool per_port_mp)
+ {
+ uint32_t n_mbufs;
+
++ if (getenv("DPDK_NUM_MBUF")) {
++ n_mbufs = atoi(getenv("DPDK_NUM_MBUF"));
++ return n_mbufs;
++ }
++
+ if (!per_port_mp) {
+ /* Shared memory are being used.
+ * XXX: this is a really rough method of provisioning memory.
+--
+2.17.1
+
diff --git a/bsp/meta-freescale/recipes-extended/ovs-dpdk/ovs-dpdk_2.9.bb b/bsp/meta-freescale/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
index ab351f6c..9b5d2516 100644
--- a/bsp/meta-freescale/recipes-extended/ovs-dpdk/ovs-dpdk_2.9.bb
+++ b/bsp/meta-freescale/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
@@ -1,14 +1,16 @@
DESCRIPTION = "OVS DPDK"
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
-DEPENDS = "dpdk python-six-native coreutils-native"
-RDEPENDS_${PN} = "bash libcrypto libssl python"
+DEPENDS = "dpdk python3-six-native coreutils-native"
+RDEPENDS_${PN} = "bash libcrypto libssl python3"
-inherit pythonnative
+inherit python3native
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1"
-SRCREV = "24eec4133f03b0a5a8f903577bc87603577150c0"
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \
+ file://0001-netdev-dpdk-have-env-based-configurable-number-of-pa.patch \
+"
+SRCREV = "71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3"
S = "${WORKDIR}/git"
@@ -45,4 +47,4 @@ do_install() {
ALLOW_EMPTY_${PN} = "1"
INHIBIT_PACKAGE_STRIP = "1"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)"
+COMPATIBLE_MACHINE = "(qoriq-arm64)"