summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-extended/pktgen-dpdk
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-freescale/recipes-extended/pktgen-dpdk
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-freescale/recipes-extended/pktgen-dpdk')
-rw-r--r--bsp/meta-freescale/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb (renamed from bsp/meta-freescale/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb)14
1 files changed, 7 insertions, 7 deletions
diff --git a/bsp/meta-freescale/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb b/bsp/meta-freescale/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
index 0a6d97de..f3a73c35 100644
--- a/bsp/meta-freescale/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb
+++ b/bsp/meta-freescale/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
@@ -1,22 +1,22 @@
DESCRIPTION = "PKTGEN DPDK"
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8120b89a783571da3cb492c35ac6b1f9"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=30ac8fa65a07ea7cc1c7ee84e1c80294"
-DEPENDS += "libpcap dpdk"
+DEPENDS += "libpcap dpdk lua lua-native"
-SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=http;nobranch=1"
-SRCREV = "ffbe7becf8dd75fd7d46b97b10374531878cb9c5"
+SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=https;nobranch=1 \
+"
+SRCREV = "7a61e4dfcdf037c31460b6c9bcb301797813036a"
S = "${WORKDIR}/git"
DPAA_VER ?= "dpaa"
export RTE_TARGET = "arm64-${DPAA_VER}-linuxapp-gcc"
-export RTE_SDK = "${RECIPE_SYSROOT}/usr/share"
+export RTE_SDK = "${RECIPE_SYSROOT}/usr/share/"
-EXTRA_OEMAKE += 'CC="${CC}" LD="${LD}" RTE_SDK="${RECIPE_SYSROOT}/usr/share" RTE_TARGET="arm64-${DPAA_VER}-linuxapp-gcc"'
+EXTRA_OEMAKE += 'CC="${CC}" LD="${LD}" RTE_SDK="${RECIPE_SYSROOT}/usr/share/" RTE_TARGET="arm64-${DPAA_VER}-linuxapp-gcc"'
do_compile() {
- unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS
oe_runmake
}