summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb b/bsp/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb
new file mode 100644
index 00000000..94649477
--- /dev/null
+++ b/bsp/meta-freescale/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "SKMM application for PCIe endpoint"
+SECTION = "skmm-ep"
+LICENSE = "BSD & GPLv2"
+LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
+
+DEPENDS = "libedit openssl virtual/kernel"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;branch=sdk-v2.0.x \
+ file://add-two-missing-header-files.patch \
+"
+SRCREV = "de6816c7d66129683bc62229b482ac3cf585d896"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'ARCH=${TARGET_ARCH} MACHINE=${MACHINE} EXTRA_LDFLAGS="${LDFLAGS}"'
+
+export LIBEDIT_CFLAGS = "`pkg-config --cflags libedit`"
+export LIBEDIT_LDFLAGS = "`pkg-config --libs --static libedit`"
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+COMPATIBLE_MACHINE = "(p4080ds|t4240qds|c293pcie)"