summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb b/bsp/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb
new file mode 100644
index 00000000..57fbbe42
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/ceetm/ceetm_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "CEETM TC QDISC"
+LICENSE = "GPLv2 & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bac620b9883d38a84dfb73ca7122d915"
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ceetm;nobranch=1"
+SRCREV = "6a7f2ec2091df2f4380cb8d25a36c399aed5af1b"
+
+DEPENDS = "iproute2"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" IPROUTE2_DIR="{STAGING_DIR_TARGET}"'
+
+do_install(){
+ mkdir -p ${D}/${libdir}/tc
+ cp ${S}/q_ceetm.so ${D}/${libdir}/tc/
+}
+
+FILES_${PN} += "${libdir}/tc"
+INHIBIT_PACKAGE_STRIP = "1"
+
+COMPATIBLE_MACHINE = "(qoriq)"
+PACKAGE_ARCH = "${MACHINE_SOCARCH}"
+