summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-kernel/dtc/dtc-145_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-kernel/dtc/dtc-145_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-kernel/dtc/dtc-145_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-kernel/dtc/dtc-145_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-kernel/dtc/dtc-145_git.bb b/bsp/meta-freescale/recipes-kernel/dtc/dtc-145_git.bb
new file mode 100644
index 00000000..2d4097bb
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/dtc/dtc-145_git.bb
@@ -0,0 +1,20 @@
+require recipes-kernel/dtc/dtc.inc
+
+LIC_FILES_CHKSUM = " \
+ file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c \
+"
+
+SRCREV = "22a65c5331c22979d416738eb756b9541672e00d"
+
+SRC_URI += "file://0001-Fix-compiler-warnings-seen-with-musl.patch \
+ "
+S = "${WORKDIR}/git"
+
+# only install the dtc binary renamed to dtc-145
+do_install () {
+ install -d ${D}/${bindir}
+ install -m 755 dtc ${D}/${bindir}/dtc-145
+}
+
+BBCLASSEXTEND = "native nativesdk"