summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-security/optee/optee-client-qoriq.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-freescale/recipes-security/optee/optee-client-qoriq.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-freescale/recipes-security/optee/optee-client-qoriq.bb')
-rw-r--r--bsp/meta-freescale/recipes-security/optee/optee-client-qoriq.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-security/optee/optee-client-qoriq.bb b/bsp/meta-freescale/recipes-security/optee/optee-client-qoriq.bb
new file mode 100644
index 00000000..6aaf714c
--- /dev/null
+++ b/bsp/meta-freescale/recipes-security/optee/optee-client-qoriq.bb
@@ -0,0 +1,31 @@
+SUMMARY = "OPTEE Client"
+HOMEPAGE = "https://github.com/qoriq-open-source/optee_client"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
+
+inherit pythonnative systemd
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/optee_client;nobranch=1 \
+ file://0001-GCC-8-format-truncation-error.patch \
+ file://0001-flags-CFLAGS-add-Wno-cpp.patch \
+"
+S = "${WORKDIR}/git"
+
+SRCREV = "ab3c79ccd3ea9323e236d30037977c0a19944dbd"
+
+EXTRA_OEMAKE = "ARCH=arm64"
+
+do_install() {
+ oe_runmake install
+
+ install -D -p -m0755 ${S}/out/export/bin/tee-supplicant ${D}${bindir}/tee-supplicant
+
+ install -D -p -m0644 ${S}/out/export/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0
+ ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so
+ ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1
+
+ cp -a ${S}/out/export/include ${D}/usr/
+}
+
+COMPATIBLE_MACHINE = "(qoriq)"