summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb')
-rw-r--r--bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb b/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
new file mode 100644
index 00000000..f7725f31
--- /dev/null
+++ b/bsp/meta-intel/recipes-bsp/thermald/thermald_1.8.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Linux thermal daemon"
+
+DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
+overheating of platforms. This daemon monitors temperature and applies \
+compensation using available cooling methods."
+
+HOMEPAGE = "https://github.com/01org/thermal_daemon"
+
+DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
+DEPENDS_append_libc-musl = " argp-standalone"
+DEPENDS_append_toolchain-clang = " openmp"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
+
+SRC_URI = "git://github.com/intel/thermal_daemon/ \
+ file://0001-Use-correct-format-specifier-for-size_t.patch \
+ "
+SRCREV = "517c0e5f92d49aeeef3a22b04caf40d588216827"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools systemd
+
+FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
+
+SYSTEMD_SERVICE_${PN} = "thermald.service"
+
+COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
+CONFFILES_${PN} = " \
+ ${sysconfdir}/thermald/thermal-conf.xml \
+ ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
+ "
+
+UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"