summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-core/images/core-image-tiny.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-intel/recipes-core/images/core-image-tiny.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-intel/recipes-core/images/core-image-tiny.bb')
-rw-r--r--bsp/meta-intel/recipes-core/images/core-image-tiny.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/bsp/meta-intel/recipes-core/images/core-image-tiny.bb b/bsp/meta-intel/recipes-core/images/core-image-tiny.bb
deleted file mode 100644
index 6b09b0c2..00000000
--- a/bsp/meta-intel/recipes-core/images/core-image-tiny.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "A tiny image just capable of allowing a device to boot from RAM, \
-this image recipe generates an image file which rather boots from initrd than \
-from storage, it achieves this by using wic to pick up the artifacts generated \
-by the core-image-tiny-initramfs image"
-
-# The actual rootfs/initrd will be the one from core-image-tiny-initramfs, so
-# we reset IMAGE_INSTALL to avoid building other things that will be pointless
-IMAGE_INSTALL = ""
-
-# Do not pollute the initrd image with rootfs features
-IMAGE_FEATURES = ""
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "MIT"
-
-IMAGE_ROOTFS_SIZE ?= "8192"
-
-IMAGE_FSTYPES = "wic"
-inherit core-image
-
-# We get some parts from image-live that we need in order to boot from initrd
-INITRD_IMAGE_LIVE ?= "core-image-tiny-initramfs"
-
-python() {
- image_b = d.getVar('IMAGE_BASENAME')
- initrd_i = d.getVar('INITRD_IMAGE_LIVE')
- if image_b == initrd_i:
- bb.error('INITRD_IMAGE_LIVE %s cannot use the requested IMAGE_FSTYPE' % initrd_i)
- bb.fatal('Check IMAGE_FSTYPES and INITRAMFS_FSTYPES settings.')
- elif initrd_i:
- d.appendVarFlag('do_image', 'depends', ' %s:do_image_complete' % initrd_i)
-}
-
-WKS_FILE_intel-corei7-64 = "core-image-tiny.wks.in"
-WKS_FILE_intel-core2-32 = "core-image-tiny.wks.in"