summaryrefslogtreecommitdiffstats
path: root/bsp/meta-intel/recipes-kernel/intel-ethernet/ixgbe_5.5.2.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-intel/recipes-kernel/intel-ethernet/ixgbe_5.5.2.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-intel/recipes-kernel/intel-ethernet/ixgbe_5.5.2.bb')
-rw-r--r--bsp/meta-intel/recipes-kernel/intel-ethernet/ixgbe_5.5.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/bsp/meta-intel/recipes-kernel/intel-ethernet/ixgbe_5.5.2.bb b/bsp/meta-intel/recipes-kernel/intel-ethernet/ixgbe_5.5.2.bb
new file mode 100644
index 00000000..28d5e980
--- /dev/null
+++ b/bsp/meta-intel/recipes-kernel/intel-ethernet/ixgbe_5.5.2.bb
@@ -0,0 +1,37 @@
+SUMMARY="ixgbe kernel driver for Intel Magnolia Park 10GbE"
+DESCRIPTION="The ixgbe driver supports 82598- and 82599-based \
+PCI Express* 10 Gigabit Network Connections."
+
+HOMEPAGE = "https://sourceforge.net/projects/e1000/"
+SECTION = "kernel/network"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}/COPYING;md5=a216b4192dc6b777b6f0db560e9a8417"
+
+SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbe%20stable/${PV}/${BP}.tar.gz \
+ file://0001-ixgbe-skip-host-depmod.patch \
+ "
+
+SRC_URI[md5sum] = "678514cb0e24f1c11d53d156a9845e64"
+SRC_URI[sha256sum] = "1c1386e4eb0b4526d2edeb04cac657e1d74c2e5cef3f2d00a26a23926744ef1a"
+
+S = "${WORKDIR}/${BP}/src"
+MODULES_INSTALL_TARGET = "install"
+
+EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
+
+KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbe"
+KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbe"
+
+inherit module
+
+do_install_append () {
+ # Install scripts/set_irq_affinity
+ install -d ${D}${sysconfdir}/network
+ install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network
+
+ rm -rf ${D}${prefix}/man
+}
+
+PACKAGES += "${PN}-script"
+
+FILES_${PN}-script += "${sysconfdir}/network/set_irq_affinity"