summaryrefslogtreecommitdiffstats
path: root/bsp/meta-qcom/dynamic-layers/openembedded-layer/recipes-graphics/images/qcom-x11-image.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-qcom/dynamic-layers/openembedded-layer/recipes-graphics/images/qcom-x11-image.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-qcom/dynamic-layers/openembedded-layer/recipes-graphics/images/qcom-x11-image.bb')
-rw-r--r--bsp/meta-qcom/dynamic-layers/openembedded-layer/recipes-graphics/images/qcom-x11-image.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/bsp/meta-qcom/dynamic-layers/openembedded-layer/recipes-graphics/images/qcom-x11-image.bb b/bsp/meta-qcom/dynamic-layers/openembedded-layer/recipes-graphics/images/qcom-x11-image.bb
new file mode 100644
index 00000000..9376de1a
--- /dev/null
+++ b/bsp/meta-qcom/dynamic-layers/openembedded-layer/recipes-graphics/images/qcom-x11-image.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Basic X11 graphics image"
+
+IMAGE_FEATURES += "splash package-management debug-tweaks ssh-server-openssh hwcodecs x11 tools-debug"
+
+LICENSE = "MIT"
+
+inherit core-image features_check extrausers
+
+# let's make sure we have a good image..
+REQUIRED_DISTRO_FEATURES = "x11"
+
+# make sure we boot to desktop
+# by default and without x11-base in IMAGE_FEATURES we default to multi-user.target
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+CORE_IMAGE_BASE_INSTALL += " \
+ alsa-utils-aplay \
+ coreutils \
+ glmark2 \
+ gptfdisk \
+ gstreamer1.0-plugins-bad-meta \
+ gstreamer1.0-plugins-base-meta \
+ gstreamer1.0-plugins-good-meta \
+ gtkperf \
+ kernel-modules \
+ kmscube \
+ mesa-demos \
+ openbox \
+ rsync \
+"