summaryrefslogtreecommitdiffstats
path: root/bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb')
-rw-r--r--bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb b/bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb
new file mode 100644
index 00000000..aba3cec1
--- /dev/null
+++ b/bsp/meta-qcom/recipes-devtools/qdl/qdl_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "QDL flasing tool"
+HOMEPAGE = "https://github.com/andersson/qdl.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://qdl.c;beginline=1;endline=31;md5=1c7d712d897368d3d3c161e5493efc6a"
+
+DEPENDS = "libxml2"
+DEPENDS_append_class-target = " udev "
+
+inherit pkgconfig
+
+SRCREV = "760b3dffb03d2b7dfb82c6eac652a092f51c572d"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
+ file://0001-Makefile-Use-pkg-config-for-libxml2-detection.patch"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix}
+}
+
+BBCLASSEXTEND = "native nativesdk"