summaryrefslogtreecommitdiffstats
path: root/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb')
-rw-r--r--bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb b/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb
new file mode 100644
index 00000000..e5e74636
--- /dev/null
+++ b/bsp/meta-qcom/recipes-support/qrtr/qrtr_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Qualcomm QRTR applications and library"
+HOMEPAGE = "https://github.com/andersson/qrtr.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=15329706fbfcb5fc5edcc1bc7c139da5"
+
+inherit systemd
+
+SRCREV = "a1694a1c938fdcd047553841370ebe2cd7384299"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
+SRC_URI += "file://qrtr.service"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS}'"
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+
+ sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/qrtr.service
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/qrtr.service ${D}${systemd_unitdir}/system
+}
+
+SYSTEMD_SERVICE_${PN} = "qrtr.service"
+
+PACKAGES =+ "qrtr-apps"
+FILES_qrtr-apps = "${bindir}/*"