summaryrefslogtreecommitdiffstats
path: root/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb')
-rw-r--r--bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb b/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb
new file mode 100644
index 00000000..2e79bc04
--- /dev/null
+++ b/bsp/meta-qcom/recipes-support/rmtfs/rmtfs_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "RMTFS QMI service"
+HOMEPAGE = "https://github.com/andersson/mrtfs.git"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ca25dbf5ebfc1a058bfc657c895aac2f"
+
+inherit systemd
+
+SRCREV = "0d3c49ec5aa27517afec9f18a3afc4b0800e6cbb"
+SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https"
+SRC_URI += "file://rmtfs.service"
+DEPENDS = "qmic-native qrtr udev"
+
+PV = "0.0+${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "'LDFLAGS=${TARGET_LDFLAGS} -L${STAGING_LIBDIR} -lqrtr -ludev'"
+
+do_install () {
+ oe_runmake install DESTDIR=${D} prefix=${prefix}
+
+ sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/rmtfs.service
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/rmtfs.service ${D}${systemd_unitdir}/system
+}
+
+SYSTEMD_SERVICE_${PN} = "rmtfs.service"
+RDEPENDS_${PN} += "qrtr"