summaryrefslogtreecommitdiffstats
path: root/bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb')
-rw-r--r--bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
new file mode 100644
index 00000000..466f4438
--- /dev/null
+++ b/bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
+LICENSE = "Proprietary"
+
+LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=4a4d169737c0786fb9482bb6d30401d1"
+
+inherit deploy nopackages
+
+include recipes-bsp/common/firmware.inc
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+DEPENDS = "rpi-config"
+
+COMPATIBLE_MACHINE = "^rpi$"
+
+S = "${RPIFW_S}/boot"
+
+PR = "r3"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/${PN}
+
+ for i in ${S}/*.elf ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+ for i in ${S}/*.dat ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+ for i in ${S}/*.bin ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+
+ # Add stamp in deploy directory
+ touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
+}
+
+addtask deploy before do_build after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+