summaryrefslogtreecommitdiffstats
path: root/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb')
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
new file mode 100644
index 00000000..9cedf5ec
--- /dev/null
+++ b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi."
+HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
+SECTION = "devel/libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.md;beginline=244;endline=268;md5=86d10e4bcf4b4014d306dde7c1d2a80d"
+
+SRC_URI = "git://github.com/sarfata/pi-blaster \
+ file://remove-initscript-lsb-dependency.patch \
+ file://0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+SRCREV = "e981aa5d7624c75a4d4afcddcbd235f25e32ffe4"
+
+inherit update-rc.d autotools
+
+INITSCRIPT_PACKAGES = "${PN}"
+INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
+INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
+
+COMPATIBLE_MACHINE = "^rpi$"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"