summaryrefslogtreecommitdiffstats
path: root/bsp/meta-raspberrypi/recipes-devtools/pi-blaster
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-raspberrypi/recipes-devtools/pi-blaster
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-raspberrypi/recipes-devtools/pi-blaster')
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch32
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch96
-rw-r--r--bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb24
3 files changed, 152 insertions, 0 deletions
diff --git a/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch
new file mode 100644
index 00000000..b4bc4b28
--- /dev/null
+++ b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch
@@ -0,0 +1,32 @@
+From 6a6b705ff5cba960c54bdb4d4bcdaa3b00a854a2 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 11 Aug 2018 10:24:24 -0700
+Subject: [PATCH] pi-blaster: Include sys/sysmacros.h for makedev()
+
+In glibc 2.28+ this header is not included indirectly anymore
+
+fixes
+
+ld: pi-blaster.o: in function `mbox_open':
+pi-blaster.c:(.text+0x28): undefined reference to `makedev'
+collect2: error: ld returned 1 exit status
+
+Upstream-Status: Submitted [https://github.com/sarfata/pi-blaster/pull/100]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ pi-blaster.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pi-blaster.c b/pi-blaster.c
+index 6cfd010..fc4e686 100644
+--- a/pi-blaster.c
++++ b/pi-blaster.c
+@@ -41,6 +41,7 @@ static char VERSION[] = "SNAPSHOT";
+ #include <sys/time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <fcntl.h>
+ #include <sys/mman.h>
+ #include "mailbox.h"
diff --git a/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch
new file mode 100644
index 00000000..c8afe60e
--- /dev/null
+++ b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/files/remove-initscript-lsb-dependency.patch
@@ -0,0 +1,96 @@
+From 1338f98a279616f4e5e9ea30a25d1dfa0c7df5d6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petter=20Mab=C3=A4cker?= <petter@technux.se>
+Date: Sun, 4 Jun 2017 12:22:40 +0200
+Subject: [PATCH] Remove dependencies on LSB functions
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+See this as a rebase of the previous 'Remove dependencies on LSB
+functions patch' with only minor modifications from the original version,
+based on the work done by Alex Lennon <ajlennon@dynamicdevices.co.uk> in
+'25fd817 pi-blaster: Added recipe'.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Petter Mabäcker <petter@technux.se>
+---
+ debian/pi-blaster.init | 38 +++++++-------------------------------
+ 1 file changed, 7 insertions(+), 31 deletions(-)
+
+diff --git a/debian/pi-blaster.init b/debian/pi-blaster.init
+index b142d70..01a686c 100644
+--- a/debian/pi-blaster.init
++++ b/debian/pi-blaster.init
+@@ -28,12 +28,12 @@ SCRIPTNAME=/etc/init.d/$NAME
+ [ -r /etc/default/$NAME ] && . /etc/default/$NAME
+
+ # Load the VERBOSE setting and other rcS variables
+-. /lib/init/vars.sh
++#. /lib/init/vars.sh
+
+ # Define LSB log_* functions.
+ # Depend on lsb-base (>= 3.2-14) to ensure that this file is present
+ # and status_of_proc is working.
+-. /lib/lsb/init-functions
++#. /lib/lsb/init-functions
+
+ #
+ # Function that starts the daemon/service
+@@ -77,48 +77,24 @@ do_stop()
+
+ case "$1" in
+ start)
+- [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
++ [ "$VERBOSE" != no ] && echo "Starting $DESC" "$NAME"
+ do_start
+- case "$?" in
+- 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
+- 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
+- esac
+ ;;
+ stop)
+- [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
++ [ "$VERBOSE" != no ] && echo "Stopping $DESC" "$NAME"
+ do_stop
+- case "$?" in
+- 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
+- 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
+- esac
+- ;;
+- status)
+- status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
+ ;;
+ restart|force-reload)
+ #
+ # If the "reload" option is implemented then remove the
+ # 'force-reload' alias
+ #
+- log_daemon_msg "Restarting $DESC" "$NAME"
++ echo "Restarting $DESC" "$NAME"
+ do_stop
+- case "$?" in
+- 0|1)
+- do_start
+- case "$?" in
+- 0) log_end_msg 0 ;;
+- 1) log_end_msg 1 ;; # Old process is still running
+- *) log_end_msg 1 ;; # Failed to start
+- esac
+- ;;
+- *)
+- # Failed to stop
+- log_end_msg 1
+- ;;
+- esac
++ do_start
+ ;;
+ *)
+- echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
++ echo "Usage: $SCRIPTNAME {start|stop|restart|force-reload}" >&2
+ exit 3
+ ;;
+ esac
+--
+1.9.1
+
diff --git a/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
new file mode 100644
index 00000000..9cedf5ec
--- /dev/null
+++ b/bsp/meta-raspberrypi/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi."
+HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
+SECTION = "devel/libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.md;beginline=244;endline=268;md5=86d10e4bcf4b4014d306dde7c1d2a80d"
+
+SRC_URI = "git://github.com/sarfata/pi-blaster \
+ file://remove-initscript-lsb-dependency.patch \
+ file://0001-pi-blaster-Include-sys-sysmacros.h-for-makedev.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+SRCREV = "e981aa5d7624c75a4d4afcddcbd235f25e32ffe4"
+
+inherit update-rc.d autotools
+
+INITSCRIPT_PACKAGES = "${PN}"
+INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
+INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
+
+COMPATIBLE_MACHINE = "^rpi$"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"