summaryrefslogtreecommitdiffstats
path: root/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu/0001-Fix-QA-issue-when-build-with-Yocto.patch
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu/0001-Fix-QA-issue-when-build-with-Yocto.patch
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu/0001-Fix-QA-issue-when-build-with-Yocto.patch')
-rw-r--r--bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu/0001-Fix-QA-issue-when-build-with-Yocto.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu/0001-Fix-QA-issue-when-build-with-Yocto.patch b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu/0001-Fix-QA-issue-when-build-with-Yocto.patch
new file mode 100644
index 00000000..dbc1eccb
--- /dev/null
+++ b/bsp/meta-renesas/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu/0001-Fix-QA-issue-when-build-with-Yocto.patch
@@ -0,0 +1,34 @@
+From 5e9eff188ada13e1c1986d5611a42e0779fe7fd1 Mon Sep 17 00:00:00 2001
+From: Thao Nguyen <thao.nguyen.yb@renesas.com>
+Date: Mon, 18 Sep 2017 17:09:21 +0700
+Subject: [PATCH] Fix QA issue when build with Yocto
+
+Yocto project has updated Linker Hash Style Changed in YP2.4.
+Makefile should be updated to avoid QA error.
+
+ERROR: open-avb-1.1+gitAUTOINC+5e43fa5ae2-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: '/proj/yocto/gen3/v3.4.0-pt2/build/tmp/work/aarch64-poky-linux/open-avb/1.1+gitAUTOINC+5e43fa5ae2-r0/packages-split/open-avb-gptp/usr/bin/daemon_cl' [ldflags]
+ERROR: open-avb-1.1+gitAUTOINC+5e43fa5ae2-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
+ERROR: open-avb-1.1+gitAUTOINC+5e43fa5ae2-r0 do_package_qa: Function failed: do_package_qa
+
+Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com>
+Signed-off-by: Masaru Nagai <masaru.nagai.vx@renesas.com>
+---
+ daemons/gptp/linux/build/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/daemons/gptp/linux/build/Makefile b/daemons/gptp/linux/build/Makefile
+index 1e00b1a..99fbf84 100644
+--- a/daemons/gptp/linux/build/Makefile
++++ b/daemons/gptp/linux/build/Makefile
+@@ -131,7 +131,7 @@ LDFLAGS_G += -lpthread -lrt
+
+ CFLAGS = $(CFLAGS_G)
+ CPPFLAGS = $(CPPFLAGS_G)
+-LDFLAGS = $(LDFLAGS_G)
++LDFLAGS += $(LDFLAGS_G)
+
+ all: $(OBJ_DIR)/daemon_cl
+
+--
+1.9.1
+