summaryrefslogtreecommitdiffstats
path: root/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb')
-rw-r--r--bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb b/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb
new file mode 100644
index 00000000..d97f0708
--- /dev/null
+++ b/bsp/meta-sancloud/recipes-bsp/u-boot/u-boot-script-bbe.bb
@@ -0,0 +1,20 @@
+SUMMARY = "U-boot script for the BBE"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS = "u-boot-mkimage-native"
+
+SRC_URI = "file://boot.cmd"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_compile() {
+ mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
+}
+
+do_install() {
+ install -d ${D}/boot
+ install -m 0644 boot.scr ${D}/boot
+}
+
+FILES_${PN} = "/boot"