summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/dsptop/libulm_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/dsptop/libulm_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/dsptop/libulm_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/dsptop/libulm_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/dsptop/libulm_git.bb b/bsp/meta-ti/recipes-bsp/dsptop/libulm_git.bb
new file mode 100644
index 00000000..7bf7f090
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/dsptop/libulm_git.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "TI dsptop utility."
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://../debian/copyright;md5=309825aa8f5edfcf2c44912ac094b979"
+
+DEPENDS = "ti-cgt6x-native"
+PR = "${INC_PR}.0"
+
+S = "${WORKDIR}/git/dsptop/ulm"
+
+DEVICE=""
+DEVICE_dra7xx = "DRA7xx"
+DEVICE_keystone = "C66AK2Hxx"
+
+EXTRA_OEMAKE = "release DEVICE=${DEVICE} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_compile() {
+ oe_runmake arm XPORT_ONLY CC="${CC}"
+ oe_runmake dsp C6X_C_DIR=${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x/include
+}
+
+do_install() {
+ install -d ${D}${includedir}
+ install -d ${D}${libdir}
+ install -d ${D}${datadir}/ti/ulm
+ cp -f tiulm.h ${D}${includedir}
+ cp -f release/libtiulm.a ${D}${libdir}
+ cp -f tiulm.h ${D}${datadir}/ti/ulm
+ cp -f release/libtiulm.ae66 ${D}${datadir}/ti/ulm
+}
+
+COMPATIBLE_MACHINE = "dra7xx|keystone"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES_${PN}-dev += "\
+ ${datadir}/ti/ulm \
+"
+
+include dsptop.inc
+
+ALLOW_EMPTY_${PN} = "1"
+
+PARALLEL_MAKE= ""