summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb b/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
new file mode 100644
index 00000000..ed30ef45
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/ibl-boot/ibl-boot-rtos_git.bb
@@ -0,0 +1,63 @@
+SUMMARY = "Second stage bootloader for c66x"
+DESCRIPTION = "The Intermediate Bootloader (IBL) is a second stage \
+bootloader for the c66x family of embedded processors. This second \
+stage bootloader takes care of additional initializations, advisory \
+setups, and errata workarounds that are not present in the first stage boot."
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://src/ibl.h;beginline=1;endline=34;md5=ee7d7a3305d1e524955996d1c5e31cb9"
+
+require recipes-ti/includes/ti-paths.inc
+
+DEPENDS = "ti-cgt6x-7-native"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "c66x"
+
+BRANCH = "master"
+SRC_URI = "git://git.ti.com/keystone-rtos/ibl.git;protocol=git;branch=${BRANCH}"
+SRCREV = "f7ed32cc8911e3353dd01080da9b725b44a12285"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+PATH_prepend = "${TI_CGT6X_7_INSTALL_DIR}/bin:"
+
+IBLTARGETS = ""
+IBLTARGETS_c665x-evm = "evm_c6657_i2c"
+IBLTARGETS_c667x-evm = "evm_c6678_i2c"
+
+IBLENDIAN = ""
+IBLENDIAN_c665x-evm = "little big"
+IBLENDIAN_c667x-evm = "little big"
+
+export C6X_BASE_DIR="${TI_CGT6X_7_INSTALL_DIR}"
+export TOOLSC6X="${C6X_BASE_DIR}"
+export TOOLSC6XDOS="${C6X_BASE_DIR}"
+export TOOLSBIOSC6XDOS="${C6X_BASE_DIR}"
+export PDK_INSTALL_PATH = "${PDK_INSTALL_DIR}/packages"
+
+do_compile() {
+ cd src/make
+ for t in ${IBLTARGETS}
+ do
+ for e in ${IBLENDIAN}
+ do
+ make ${t} ENDIAN=${e} I2C_BUS_ADDR=0x51
+ done
+ done
+ cd -
+}
+
+do_install() {
+ install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/ibl
+ cp -rP --preserve=mode,links,timestamps --no-preserve=ownership * ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/ibl
+}
+
+FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages"
+
+INHIBIT_PACKAGE_STRIP = "1"
+INHIBIT_SYSROOT_STRIP = "1"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+INSANE_SKIP_${PN} = "arch file-rdeps"