summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/ipumm-fw
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-ti/recipes-bsp/ipumm-fw
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/ipumm-fw')
-rw-r--r--bsp/meta-ti/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch48
-rw-r--r--bsp/meta-ti/recipes-bsp/ipumm-fw/ipumm-fw_git.bb24
2 files changed, 60 insertions, 12 deletions
diff --git a/bsp/meta-ti/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch b/bsp/meta-ti/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch
new file mode 100644
index 00000000..0bea358f
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/ipumm-fw/files/0001-HACK-ipumm-Workaround-for-linker-error.patch
@@ -0,0 +1,48 @@
+From 7226700841c62e6a42690eaa8b3e31b2c329b341 Mon Sep 17 00:00:00 2001
+From: Ramprasad N <x0038811@ti.com>
+Date: Thu, 28 May 2020 09:53:59 +0530
+Subject: [PATCH] HACK: ipumm: Workaround for linker error
+
+* HACK: ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E is no longer
+* defined with latest XDC tools. To temporarily get around the issue
+* until the real fix can be made, dummy defination of the missing function
+* is added in ipu_main.c
+
+*IPUMM dependent tool chain components are upgraded to latest version
+* BIOS : 6_82_01_17_eng
+* XDC : 3_61_00_16_core
+* This issue is seen only with xdc tools upgrade.
+
+Signed-off-by: Angela Stegmaier <angelabaker@ti.com>
+Signed-off-by: Ramprasad N <x0038811@ti.com>
+---
+ platform/ti/dce/baselib/ipumm_main.c | 13 +++++++++++++
+ 1 file changed, 13 insertions(+)
+
+diff --git a/platform/ti/dce/baselib/ipumm_main.c b/platform/ti/dce/baselib/ipumm_main.c
+index 76ccd34..f4ca6e5 100644
+--- a/platform/ti/dce/baselib/ipumm_main.c
++++ b/platform/ti/dce/baselib/ipumm_main.c
+@@ -50,6 +50,19 @@
+ #include <string.h>
+ #include <stdlib.h>
+
++/*
++ * HACK: ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E is no longer
++ * defined with latest XDC tools. To temporarily get around the issue
++ * until the real fix can be made, define the missing function
++ * here.
++ */
++extern ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__F(xdc_Int state);
++
++/* Module_startup */
++xdc_Int ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__E( xdc_Int state )
++{
++ return ti_sdo_ce_utils_syscbuf_SysCBuf_Module_startup__F(state);
++}
+
+ /* Legacy function to allow Linux side rpmsg sample tests to work: */
+ extern void start_ping_tasks();
+--
+1.9.1
+
diff --git a/bsp/meta-ti/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/bsp/meta-ti/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
index 5cb38b05..e53d0a98 100644
--- a/bsp/meta-ti/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
+++ b/bsp/meta-ti/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
@@ -1,28 +1,28 @@
-python __anonymous() {
- features = d.getVar("MACHINE_FEATURES")
- if not features:
- return
- if "mmip" not in features:
- raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES')
-}
-
-DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode"
+SUMMARY = "Firmware for IPU to suppor Accelerated MM decode and encode"
LICENSE = "TI-TSPA"
LIC_FILES_CHKSUM = "file://Texas_Instruments_ipumm_Manifest.pdf;md5=5cc572579f07af266ab57fc17d762c7f"
COMPATIBLE_MACHINE = "dra7xx"
-RDEPENDS_${PN} = " libdce"
+inherit features_check
+
+REQUIRED_MACHINE_FEATURES = "mmip"
+
+RDEPENDS_${PN} = "libdce"
SRC_URI = "git://git.ti.com/ivimm/ipumm.git;protocol=git"
-SRCREV = "e4872a8966a267d537399b1babc54e5f66ae8b3b"
+SRCREV = "df4c50aecc9aad7ab3eb1ca9ebacfe473fcad7c5"
+
+SRC_URI += " \
+ file://0001-HACK-ipumm-Workaround-for-linker-error.patch \
+ "
S = "${WORKDIR}/git"
PV = "3.00.15.00"
-PR = "r4"
+PR = "r6"
require recipes-ti/includes/ti-paths.inc